11.8 x64 - Program Not Responding

I read through the earlier post regarding the user having problems switching toolbars and I don't believe this is the same problem.
After upgrading to 11.8 I have noticed from time to time that DOPUS just 'hangs' - I get the "program not responding' message in the title bar.

  • Upon the first time I open a lister - Even if I close all listers then open again a brand new one this will happen - It waits about 10 seconds then all of a sudden comes to life and everything is ok for awhile
  • seemingly at random when I move to a different directory (can't see a pattern)
  • When typing in the search panel

I have a Lenovo laptop all SSD running latest patched version of WIndows 7. Prior to upgrading to 11.8 never saw this issue.
Was running KODC theme - I completely uninstalled DOPUS, reinstalled using default configuration - still seeing same problem.
If I could reinstall the 11.7 version I would (to try it) but I can't find it to download. (will do this if somebody can send me a link to try it

Any suggestions welcome.

Here's the 11.7 installer to test that theory: leo.dopus.com/temp/DOpusInstall_11_7_x64.exe

The Windows 7 OS also got the Nov. update for its' Windows Defender too. If version 11.7 doesn't work out for you, then you might try turning off Windows Defender, like I did, to see if things go back to normal. Trust me, it will save you hours of trying things, if that is indeed the cause....

Thanks for responses

  1. Windows Defender not running (I'll try my regular anti-virus and disable but haven't tried it yet)
  2. Behavior same under 11.7 unfortunately
  3. Only had one other program installed recently (Display Fusion) - I both turned it off and uninstalled it. No change in the DOPUS behavior.
  4. Looked at Process Monitor but nothing stood out. Maybe a bit of disk access but no excess CPU cycles or anything.

Any other suggestions?

There might be something in your toolbars which points to a path on a drive which has gone to sleep, and takes time to spin-up, or on a network drive which is inaccessible (or just very slow), and has to timeout before failing.

Some updates -

  1. On starting a lister I actually timed it - It is closer to 30 seconds before the files windows on the right side populate

  2. It is the left side with the folder tree that exhibits the strangest behavior - that takes minutes to populate the directory structure- 1 directory in the tree will show itself, then time goes by then the next directory appears, etc. The mouse cursor displays the waiting symbol whenever it is over the folder tree area.

  3. I can access a file in the file area if it shows up no problem though

  4. I deleted the only network drive I had mapped - however DOPUS exhibits this behavior whether the network drive is available or not, mapped or not.

  5. I have attached screen shots - I noticed that even though the network drive is disconnected - (L:) it still shows up on the DOPUS side. Also - with that one network drive mapped I never noticed this behavior in the past.
    SCR1 - First after opening
    SCR2 - About 1 minute later (desktop (bottom lister window)
    SCR3 - Switch to make top window active
    SCR4 - About 1 minute after making top window active - You can see directory tree more fully defined)

  6. I ran hardware checks on the entire machine (but especially the ssd) - Everything passed OK.

So it's the tree expansion that's slow?

Does this thread seem relevant?

Yes - So it appears. I'm kind of at a loss what to do next, especially since it appeared out of the blue.

I have tried WIndows Explorer and it seems much quicker - but I have noticed from time to time when I expand a directory tree it slows down as well.

I just have never seen anything like this in DOPUS and it is the mainstay of how I navigate around my files :slight_smile:

I apologize for size of those screen shots. If there is a way to remove them please tell me how and I'll re-post in a smaller size.

Did any of the suggestions in that other thread help?

Not really because it related to changing his toolbars and mine are all the standard configuration from a default installation. So there really isn't anything to change. I gueass I could try removing the default toolbars that are already there. I'll try that later today.

No, I mean the thread I linked to: Folder Tree expansion slow w/ Microsoft Security Essentials.

Ah sorry - thank you. (brief bout with kidney stones took ME off line for a bit)

I checked out that thread. I'm not running MSE.

HOWEVER - The symptoms sound VERY similar.

I have attached the options you mentioned but it wasn't activated anyway.

I run AVG free but when I tried deactivating it it didn't seem to have any effect. I'll try de-installing completely and see what happens

I just decided to try disabling the "Virtual (non-filesystem) folders option in the screen shot and I believe that has fixed the problem. :smiley: :smiley:
I will monitor.

I do infact have such a folder (Secure Cloud storage app called Power Folder) But I have had it for 6 months and never saw a performance issue before with DOPUS.

Maybe there was some confluence of 11.8 update from DOPUS at same time there was an update from PF (which did happen).

So - I'll keep an eye on it today and see how it goes. My thanks to everybody - and thanks on that pointer to the last thread. That is what made me look in the right place and see the option to disable.