GP SoftwareTwitter
Opus FAQsManualCommandsObjects

12.9.1 beta: Windows visual style not applied toolbars & menus


#1

In version 12.7.2, the context menus and toolbars were the same style as Windows. I upgraded to version 12.9.1 and now the visual style of Windows is not applied to these elements.

On the right is the Windows context menu and on the left is the context menu of Directory Opus.
Menu%20de%20contexto


#2

In 12.9.1 the menus no longer use visual styles if you make them use a dark background color, since visual styles usually do not work with dark background colors.

Setting them to "use system colors" (the default) may work if you have a dark visual style installed.


#3

Yes, it's a great upgrade for those who like customization.

The problem is exactly this! Even with "use system colors" enabled, toolbars and context menus do not use the colors of Windows visual style. There must be some bug related to it.


#4

I tested several light and dark visual styles. It seems that Opus is having a problem using dark visual styles. The same does not happen in clear themes.

In dark visual styles Opus uses only background and selection colors of visual style. The textures of selected item, separator, etc. are not applied.

However, in light visual styles, Opus works perfectly. All visual style textures are applied.


#5

In the 12.7.2 version, Opus worked perfectly:

I use Windows 7 SP1 (6.1.7601.24094) 64-bit.


#6

Hmm, maybe the visual style having a dark background color itself is triggering the "dark colors, better not use visual styles" mode.

We'll look at that to see if it can be avoided if the color comes from the visual style and not the user overriding things in Prefs.


#7

Ok. If you can fix this, I appreciate it. I will wait for the fix in the next versions. Thank you!