Active Pane Losing Focus when Viewer Pane is open

I have a single pane opened with a viewer Pane

As I move the cursor to highlight a Microsoft Word or Excel file, the details are displayed in the viewer pane.

Problem

  1. The Active Pane (with the green bar) loses focus. I have to click within the previously Active pane in order to be able to use the down key to move down to the next file.

  2. If Internet Explorer, Firefox is open some other program is open, (but none is in the foreground), when I move the focus to a new file, the previously active application is brought to the foreground. It is as if an Alt Tab is executed.

The above problem does not manifest itself if I move the cursor and click a text file.

Could it possibly be due to something about Microsoft Word or excel being an "Activex" document because that is what is indicated in the viewer pane.

You may (or may not) be able to improve the alt-tab-like issue by going to Preferences / Plugins / ActiveX Document and enabling Alternative open method.

In terms of the focus issue there isn't a lot that can be done since ActiveX seems geared up to giving the new component (e.g. Word) the focus when it opens. You can, however, browse through files using the little next/previous arrows in the border of the viewer pane. Making system-wide hotkeys which run the Select Next and Select Prev commands is another option (if they're system-wide then it doesn't matter what has the focus).

Another alternative is to use the QuickView viewers for Word documents. These work inside of Opus if they're available and you can get them free with things like Yahoo Desktop. There's a post in the tips section with details and I'm pretty sure they don't grab the input focus or do any other weird things.

OK, Thanks.

For a quick answer, jump to the Update at the bottom and skip the part between the two --------- which documented the different methods I tried to arrive at the answer.


I found the link on configuring Yahoo Desktop Search filters and Quickview

[resource.dopus.com/t/tip-free-viewer-plugins/267/1)

I was able to improve the alt-tab-like issue by going to Preferences / Plugins / ActiveX Document and enabling Alternative open method.

However, when I pointed it the Mutiview Viewer Location to the Quickview filters which I happen to have, I noticed that the loading of the files in the View Pane was much slower than in the case of Norton Commander which also uses the same Quickview Filters. Norton Commander seems to be able to view the files much faster. The viewing pane shows the files instantaneously (practically no wait time.)

In the Dopus View Pane, I can see word (loading) appearing after the file name and the same file that loaded instantaneously in Norton Commander Quickview mode can take up to 6 secs (and the file was only a small excel file of 13.5kb.)

I wonder why ?

I tried to then point the Multiview Viewer to the Yahoo Desktop Stellant Filters. But the results were the same - ie much slower.

I thought I would then try the native Multiview.dll as the filters.
So in the Settings|Preferences|Plugins|Viewers Tab, I tried to point the Multiview Viewer Plugin to C:\Program Files\GPsoftware\Directory Opus\Viewers

But the OK button remains greyed out so I could not click it. ie the Multiview Viewer Plugin remain pointed to Quickview.

The conclusion was that when viewed with the "Activex filters in the Dopus Viewer Pane, the documents appeared instantaneously, but it did an unwanted Alt Tab until I used Alternative Open Method.

But that slowed things down.

Update :
I unchecked the ActiveX Document Filters and guess what, the documents opened in the viewer panes INSTANTANEOUSLY. And no unwanted Alt Tab Problem.

WOW !!.

Since I already documented the problem, I will just post the solution for those still pulling out their hair like I was until 2 minutes ago.

I guess Dopus was trying out the two methods and that slowed things down.

:laughing:

[quote="bookman"]
Update :
I unchecked the ActiveX Document Filters and guess what, the documents opened in the viewer panes INSTANTANEOUSLY. And no unwanted Alt Tab Problem.

WOW !!.

Since I already documented the problem, I will just post the solution for those still pulling out their hair like I was until 2 minutes ago.

I guess Dopus was trying out the two methods and that slowed things down.

:laughing:[/quote]

Another more useful tweak is to leave the ActiveX Documents Filters enable but to remove the ActiveX Document Filters for .doc and .xls or whatever else that may be bothering you.

Otherwise, you will find that swf files and other ActiveX documents cannot be viewed in the viewer pane.