Adding tags creates a copy with ".jpg11456"

What is going on?

  1. select multiple ".jpg" image files
  2. Properties>edit metadata
  3. fungi;macro; etc. enter
    now data is being written AND a copy of the file name with ".jpg11456" is created (that does not respond to "righ click" so I can't view or edit the contents.)

Could you zip and attach one of the original .jpg files for us to test with?

Sure thing, it's still in the process ow writing, as soon as it stops I'll upload.'
Included snapshot of wht the images look like in DOPUS. (4.5 MB)

They might be Temp files?

I was plagued with this problem for ages. They are temporary files. My problem is that I was writing a lot of metadata to a file via a VB Macro. The problem was that the bigger the image, or the busier my system, the more likely the temporary file was to appear.

I solved the problem by concatenating all the instructions to write the individual pieces of metadata into one command. It never happens now.

I can only imagine that the continuous opening and re-opening the file was causing the problem.

You may have a different problem, of course, as I do not know how you are adding the metadata.

I don't think this is relevant here, since we're talking about editing tags via the metadata panel and the images aren't huge.

Thanks for the test file!

I tried (separately) adding, removing and then adding more tags into the zipped image and didn't run into any problems so far, using Opus 12.12.2.

Which version are you seeing the problem on?

win 10 prox64 DOPUS 12.12x64
I think the ".jpg11456" are temp files and I'm not finding them in the folder at all, now some time has passed the data might be embedded into the official JPG file.
Reported a similar issue in another post where the file had a mysterious string of numbers after a known extension (PNG) and was not accessible.

They are temp files.

So they don't stay there after a while?

Something may be locking them from being cleaned up.

Are the changes to the main JPG being saved OK? i.e. The only issue is you're seeing these extra files, not that the original files are either missing or not being updated?

Are you doing this on a local drive, or on a NAS of some sort?

yes, I think there is some lag and that's why I can see the temp files. If I notice this on my local 7200RPM HDD, I'll give an update. :slight_smile:

It's possible the NAS is delaying the deletion for some reason, or not sending change notifications as quickly as it should.

1 Like