Admin mode without timeout?

Hi Leo

When you hit the Admin button, the longest you work as Administrator is 30 mins and it always catches me. Could you add an Infinite time option also? I normally disable Admin mode manually anyways.


You can specify a longer timeout in the command, or zero to disable the timeout entirely.

Change the Admin button to run this and it will not turn off until you click the button again:

Set ADMIN=Toggle,0

Will it be added here?



That dialog won’t appear at all, it will go straight to the UAC prompt.

Just hold your ALT-Key and right click with your mouse cursor on the Admin button in toolbar.

DO should now be in customization mode and show you this window

Now you can modify the command as Leo mentioned and press the OK button in the lower right corner and once again press the OK button in the second open window.


Thanks, this is better than the popup!

Note that this only works if you've turned on Preferences / Toolbars / Options / Alt-Click to edit Toolbar buttons.

(Left-click is more correct, too, although right-click will also work in this particular case, as the button doesn't have alternative middle/right click actions.)

You are correct, Sir! :smiley:
Works both in this case, and you are correct again about the Alt-Key. Have configured this some time ago and did not remember about this convenient setting.

1 Like