After I edit song details, columns are no longer populated

I am cleaning up my music library.
After I edit song details, columns are not always populated (Track No., Title, Artist, Album Artist, Album, Duration.

Windows File Explorer still shows the details.

Any suggestions?

What are you editing them with? Opus, or another tool?

Do the details appear again if you reload the folder after the edits are done?

I have edited both with MP3Tag and Roxio Creator Nxt Pro16, with the same result.


Directory Opus:

These results are from the same album folder, only Opus does not show the details.
As you can see, the information does not reappear afytter the edits are done, but is embedded in the files as both MP3 and Roxio can display them.

Just a wild surmise - you haven't changed the colours displayed in those columns?

How about a quick check with the Metadata pane?

No, did no change colours, other albums still display correctly, I have this problem with about 5 albums in my collection.
Checking metadata - not sure that is available in Directory Opus Light, if so I do not seem to be able to open it.
This is what I get when I look at properties:
no entry for metadata.

The pane should be available via the F9 key, if it is part of the Light version.

There was a change in 12.20.2 (beta) which added support for tags in .m4a files which used a different format to the more common one iTunes uses. That hasn't made it to the stable releases yet, but the current beta doesn't have any major known issues and is safe to install.

If you're on an earlier version, please try using the latest beta to see if that solves things.

If it doesn't, could you send us an example file? If you zip it, you should be able to send it via private message.

Thank you, Ixp, but no Metadata editing is not part of the light version.
Will need to consider upgrading to Pro IF that is the only solution to my problem.

Thanks, Leo
Downloaded Beta version but the problem persists with the same albums as before.
Tried to send a private message, but when I clack on the link it tells me
Sorry, but you cannot send a private message to Leo.
When I can, do you like the whole album or one of the tracks?

You should be able to send private messages now. -- It was blocked before due to your account being new.

Found another solution - it only happens with MP4 files, if I convert the album to MP3, it displays correctly.

If you send us an example file we may still be able to fix it.

Thanks for the offer, did send a file to Leo via private message.

Thanks for the files. We've made tags in that format work for the next update.

(As an aside, despite being M4A audio files, whatever produced or modified them has put them inside an M4V video container.)

Appreciate your efforts. Problem has been resolved for now.
Will try and establish how they ended up inside an M4V video container.