{allfile} returns bad files

Hi everybody,

here is my pb : when using the command {allfile}, sometimes files are badly returned. I use this to pass names of the files to another application.

an exemple : I select have these 3 files (under d:\temp):
toto 1.txt
toto 4.txt
toto.3.txt
I run the following command (just an exemple to show the issue) :
Clipboard SET {allfile} -path {sourcepath}
clipboard now contains this value :
"toto 1.txt" "toto 4.txttoto.3.txt" -path D:\Temp\

as you can see the third file is not between quotes but concatenated with the second one. So I have to files where only the first is good because toto 4.txttoto.3.txt does not exist.

With theses files this is worst :
toto 1.txt
toto.3.txt
toto.4.txt

result is : "toto 1.txttoto.3.txttoto.4.txt" -path D:\Temp\

but with these ones, eveithing is good (quotes are not needed):
toto.1.txt
toto.3.txt
toto.4.txt

toto.1.txt toto.3.txt toto.4.txt -path D:\Temp\

I use this command since a long time and did not notice this kind of pb, but I'm not sure having used it on this kind of files with old DOpus versions

Did someone has the same issue?
Is there a solution?

My Dopus version (the last one at this time) : 9.5.1.0.3624.x86
OS : Windows XP Pro Fr x86

Confirmed. It appears to be related to the period in the name of the last file - toto.3.txt - if you rename this to toto 3.txt then the command works as you would expect.

Regards, AB

Thanks for trying.

unfortunately my filnames are more complicated than this and I run my external application with {allfile} as argument, so if I can't trust it this I will try in earlier version of Dopus. Hope it will work well.

Anyway Dopus is seach a great program that I can forgive this anoying little bug and continue to use and abuse it...

Do I have to report it somewhere to be corrected in the next release?

Maybe I will use Clipboard COPYNAMES=nopaths (which work well) and extract each filename to get what I want 'cause I can't check every filename before runnig command.

You can click on the Contact GPSoftware link in my signature to file a report.

Regards, AB

Ok thank you.

Just for information, it works well with 9.0.0.9 release

Can you work around the problem by using {allfilepath} instead of {allfile} for now? That doesn't seem to be affected by the problem.

Thank you for your answer

I noticed that but I can't use it because the entire command line is often too long with the fullpath, that's why I use -path {sourcepath}.

Anyway I sent the bug to Technical Support Request and they answer me that this will be fixed with next release.