Another FTP problem


I am setting up a FTP server for my own use and I downloaded a program called XM Easy Personal FTP Server V4.3. Now I have set up a FTP server but when I connect to it through Directory Opus the directory is always empty no matter what I put in it! When I use FlashFXP I can see the contents of the directory just fine.

Everything seems to be working correctly on the client and server side but there is just nothing comming up in directory opus window to show the contents of the server. I can even create directories etc within Opus and see them show up on my server but still Opus refuses to get the directory listing :frowning:

I can post logs from both server and client if needed



Tried everything in this FAQ?:

[FTP Doesn't Work)

No directory listing is often PASV-mode set the wrong way. (Sometimes it only works on; sometimes only off, depending on a combination of client, network and server things.)

I don't know if it's applicable but something that sounds similar was fixed in the update which just came out:

[Directory Opus

"FTP: Fixed issue where a failed Passive (PASV) connection would retry using Active connection (PORT) but not correctly read the initial folder."

There also seems to be a bug in my routers firmware, meaning some of the commands were getting garbled (PORT became POPORT) I changed the options so the server was using passive mode and it works now. So not OPUS fault at all this time, sorry:)