Archive Took a Long Long Time

I have been using the Archive feature for some time now. It seems to produce a zip file that others can open (with other applications).

However, the last couple of days I've tried to Archive Boost and KeePass (Boost is very large (several hundred MBs). Well it did not go well. The speed was so slow that it went over night and did not finish. Furthermore every once in a while it would fail to read a block and I would have to click on "Retry".

The same directories were easily zipped by WinZip.

Which method and options are you using to create the archives?

Where can we get a copy of the same files?

Boost is the large one:
KeePass is a password vault, I build the c++ version:

I highlight the two directories and click on (select) Archive Files on the toolbar. It brings up a dialog box and I fill in the name and directory and click OK.

If you edit that button (Settings > Customize Toolbars, then right-click the button and choose Edit), does it run this command:


When I do the same test using boost_1_72_0 (64,810 files, 6,043 folders), the operation completes quickly for the amount of files, in about 30 seconds.

The longer time you're seeing could be because Opus is not using batch mode, and is opening and closing the archive for each file it adds (very slow with a huge number of files like those examples). But, unless your command has single in it somewhere (to tell it to create a separate archive for each folder), or you're using an old version of Opus, batch mode should always be used, I think.

The settings under Preferences / Zip & Other Archives / Zip Files may play a part. Here are mine for comparison:

Do you get similar speeds if you switch to using 7z instead of Zip in the dialog that the button opens?

Here are my pref and I believe I have the latest version.
My C drive is an SSD and the D drive is a rotating drive. The files are all on the the D drive.

The 7z archive is quite a bit faster and it 25% in about 3 minutes.


Try the "use temporary file" option in case that's playing a part. It'd normally make things slower but maybe not in this case.

I wonder if an antivirus scanner may also be involved in what's happening, since your 7z speed, while faster than zip, still seems quite slow compared to what I see here (even on quite an old machine, although it does have an SSD).

Sorry, I did and it did not make a significant difference. It was after that that I tried the 7z option which did make a difference.

It is curious.

1 Like

Try disabling your antivirus and see if it makes a difference.

It is late here (California). I'll try it tomorrow. Bob