@async and /min in button not working here

Hi, I tried to create a button via Standard Function that archives a single folder into a 7z file and then deletes it.

@async "C:\Program Files\7-Zip\7z.exe" -sdel a {destpath}\{file} {sourcepath}\{file}

It works fine but I would also like to not see the CLI window (sorry, CMD window :slight_smile:
I tried to a "/min" at the end but this doesn't work.

Any idea?

An additional question is: I would like to only execute this when EXACTLY one folder is selected. How can I do this?

btw. I am using async because afterwards (or rather at the same time) I want to count the MB of this folder with:

GetSizes {sourcepath}\{file}

Thanks for your help.

Cheers from Germany

@async should be @async:

/min isn't a thing, but you can add a line with @runmode:hide. But that will also hide errors etc.

Using 7zG.exe, instead of 7z.exe and hiding the cmd window, would probably be better, as then you get a proper progress and error UI.

@Leo Thanks a lot. That was as well lightning fast and additionally very helpful. I wished I had asked earlier.

Greetings to the team.

1 Like