Today I saw that a new version of Directory Opus (12.18) was released and this reminded me about what prevented me from using the program.

Even though that I believe that I have disabled auto-start, screen:

any time I start Directory Opus it is set to auto-start, screen:

so I have to open a start-up manager and manually disable auto-start, screens:

For me it is quite annoying and tedious to open a start-up manager to disable auto-start every time I exit Directory Opus so I switched to other file managers.

If I am missing something please educate me about it.

Off-topic- once there was another problem which plagued me- after update Directory Opus required restart which was highly inconvenient for me as I usually restart my machine once or twice a month. This problem was resolved (perhaps someone else reported it) so I hope the auto-start issue I described above will also be addressed.

The desktop double-click process (DOpusRT.exe, rather than DOpus.exe) is controlled via Preferences / Launching Opus / From the Desktop.

If you don't want to take advantage of being able to double-click the desktop background to open a new Opus window, turn that off. If it's off, the DOpusRT.exe process won't be run at startup.

OTOH, if you do want to use that feature, you should allow the process to run at startup, otherwise it won't work.

DOpusRT.exe is a tiny process with almost zero overhead, so there isn't really any reason not to let it run, unless you aren't using that feature.


This was really fast, I am surprised, thank you for the helpful and explanatory response!

I think this was my first post here so I don't know what I should do to close the issue as I got a completely satisfactory answer to my question.

I checked Double-click on the Desktop - Disable and my problem is really solved.


You should see a "solution" button/icon below posts for that. (Only on threads that you started.)

Using it isn't required, though. You don't have to do anything. But it can help to highlight the post with the answer in longer threads where it might be easy to miss when other people find them looking for the same thing.


Thanks again for the information provided. As I am used to GitHub issues and SourceForge tickets I was searching for a way to close this thread. I marked your first response as Solution as it was really a solution. Perhaps I might have tried to read some documentation first before opening this thread but as I had disabled auto start I didn't imagine that I should check other settings as well. Anyway, the problem is solved, rather quickly to boot, I appreciate your immediate and detailed help!