Auto-update not working correctly


I keep having a problem with the inbuilt updater which I cannot solve. Whenever there is an update, download of the file works fine, installer/updater routine runs - until it reaches all the executive files in Dopus and I am told "cannot update file when in use dopusrt.exe (for example)"

Any advice on how to solve this without having to download the update manually, closing all Dopus executives and trying to run the update? I am usually not computer illiterate, but this puzzles me. I always thought in case I need to close some processes, updater would notify me of the necessary steps, so I just clicked "install update now".

(I have searched before posting; if I have overlooked something about this problem, I am very sorry.)

Can you post a screenshot of the error you are getting?

The normal behaviour is for any in-use files to be replaced the next time you reboot, and indeed the installer should prompt you to reboot if necessary.

Therefor I'd need to manually re-install the update, which I havent downloaded just yet.
The updater did tell me to reboot, but with the error message I had only options to skip, abort or retry. So I did not get the impression this would fix itself with a reboot.
Will post the screenshot asap. Might take till tomorrow though. Thanks for your help.

Ok, download finished and I ran into the same error message:

It says exactly "a file cannot be created if it already exists - cancel - retry - ignore".

Now I clicked cancel and - oh my, it aborted the update altogether after dopus.exe had been deleted. Thank God once I ran that setup again and chose "ignore" this time, it restored the program. I received error messages for the other executive files too, though. (I had closed both file lister and Dopus rt from the system tray before starting the setup).

My file version on the "about" page now says Dopus is updated and taking in account that dopus.exe was deleted after the setup basically said it wasn't able to update that file, my guess is that the other executive files also got updated, but I am not sure at all.
Anyway this is a very strange behaviour. I would love to find a way to solve this, so that future updates run hazzle free.

Something very strange is going on there as you're installing the 64-bit version but the path in the error dialog says "Program Files (x86)".

Have you somehow migrated 32-bit Opus over from a 32-bit machine to a newer 64-bit machine or something strange like that?

No, I only installed it in the wrong folder. But I have a 64bit machine and was always using the 64bit version of Opus.

Okay, since nobody seems to have an idea, I will probably be more lucky filing a support request about this issue. Will let you know how it goes :slight_smile:

Maybe un-install completely and reinstall to the normal default (non (x86)) folder to see if that is somehow throwing things off? It seems unlikely I'll admit, but hey - funnier things happen with computers.

I've had this happen to me many times. So many times that I stopped using the auto updater. I Just download the latest version, backup my config, uninstall, install latest, restore config. EXCEPT from 10.0.2 to 10.0.3, I wanted to test for Jon and get him a screenshot (before you posted yours) but it worked this time so IDK.

As far as I know, it should be completely irrelevant into which folder you install a program. I am simply doing this for personal taste. The manual update produced the exact same error. I really do not see why I should uninstall and reinstall a program just to apply an update, and since I am not the only person with this problem, that error should be looked into by the developers. I am on and off in the next couple of weeks so I can't really tell when I will be able to file a support request on this matter.
If I get any response I will post it here.

@ktbcrash: There's no reason for it to be any different through the auto-updater as all that does is download and run the same file you are.

@MissEmerelle: I'm not aware of anyone else reporting this issue - it's something to do with your system. Check your antivirus tools etc to see if any of them are preventing the installer from writing to the program folder. I don't believe installing into a different directory will matter, but I also don't think it would hurt you to try a full uninstall (backup your configuration first) and then do a fresh install to the default location, just to see. Feel free to file a support request when you get time but you'll get told the same thing via email as you are here :slight_smile:

Sorry, should of said "updating" and not "auto updater". Yes, the auto updater just downloads the same installer from the site. It was updating that almost never worked for me so I stopped trying. I always got the same error MissEmerelle did. Where it said it could not write a file.

No big deal, I was just trying to let you know that I too had this problem before. Never cared to bring it up since others didn't complain... figured it was just my computer. Again, 10.0.2 to 10.0.3 did work (though it was in Win7 VM and not my Host Win7 x64). Can't remember now if Exiting Dopus helped the problem or not.

I'll try again on the next beta release and I'll record the screen just in case it does it again. Unless beta's are allowed to have these kinds of problems?

When I was posting this, I was not aware that developers do read and write here. Obviously I was in a hurry, - my bad!
Now, when I said I'd mail in for support, I did not expect a quick fix. I rather thought it might be something important to let development team know. And of course, I thought I'd at least get some sympathy for the money I paid for this software! :smiley:

Well, since ktbcrash already re-confirmed, he does seem have the very same problem with the update. Neither shutting down the antivir monitor nor a re-install did solve this behaviour for me, quite the contrary: the second time around I not only had the above error message, but when I clicked ignore as I did before, the concerning files were not written at all. In other words, dopus.exe etc were entirely missing from the folder. Only a removal and fresh install could get the necessary files are back.

I could live with a manual update, but this was very odd and inconvenient, to say the least.