GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Autodesk Context Menu


#1

Before I upgrade it to Directory Opus 10, Directory Opus 9 shown context menu for Autodesk Inventor. Now I can’t find it in Directory Opus 10 but it still appears in Windows Explorer context menu. See screenshots below.





#2

Did you just upgrade from 9 to 10, or has it been a while since you saw the menu working in (any version of) Opus?

Unfortunately, I don't have access to Autodesk Inventor so I can't look at how it registers its context menu items. If you can do the two things below, it might shine some light on where things are going wrong.

(I'm assuming that you are using the latest version of Opus; either 10.0.4.0 for the latest stable version or 10.0.4.1 for the latest beta version.)

[ul][li]Go to Preferences - Miscellaneous - Advanced and turn on context_menu_debug.

Download the small DebugView tool from Microsoft and run it. If you see an error message about extracting Dbgv.sys you can ignore it as we are not interested in debugging device drivers.

Right-click one of the .idw files in Opus.

DebugView should display a bunch of numbers in {...} and the names of some of the context menu shell extensions on your computer. Please copy & paste that list in a reply or private message.

[/li]
[li]Also, while you are looking at Preferences - Miscellaneous - Advanced, make sure the ignore_context_menus setting is empty.

If that isn't empty then it is usually because a context menu crashed in the past, and Opus moved it into the list so that it would not cause further problems. But sometimes the crashes are a one-off and it's safe to reset the list.

[/li]
[li]Grab FileTypeDiag from my personal site, then run it against the .idw extension.

It should create a text file in the location of your choosing. Please zip that up and send it to me via a private message or attached to a reply.[/li][/ul]

Thanks!


#3

What happens if you "Shift+Right Click" in Opus?


#4

I have the same thing as shown in Directory Opus screenshot.


#5

Thus ruling out one of the more obvious reasons for this behaviour, and leaving you in Leo's safe hands.


#6

Hi bebiboi,

Many thanks for sending the two logs.

Please check if these two files exists:

[ul][li]C:\Program Files\Autodesk\Inventor 2012\Bin\DtBridge.dll[/li]
[li]C:\Program Files (x86)\Autodesk\Inventor 2012\Bin\DtBridge.dll[/li][/ul]

Do both exist, or only one?


#7

[quote="leo"]Hi bebiboi,

Many thanks for sending the two logs.

Please check if these two files exists:

[ul][li]C:\Program Files\Autodesk\Inventor 2012\Bin\DtBridge.dll[/li]
[li]C:\Program Files (x86)\Autodesk\Inventor 2012\Bin\DtBridge.dll[/li][/ul]

Do both exist, or only one?[/quote]

Dear Leo,
I searched on my computer and here what I have on it.

C:\Program Files\Autodesk\Inventor 2012\Bin\DtBridge.dll
C:\Program Files\Autodesk\Inventor 2012\Bin\Bin32\DtBridge.dll

Thank you for your help.


#8

Thanks! That looks correct, which rules out what I thought the problem might be.

I discovered that I can download a trial version of Autodesk Inventor 2012, so I will try that when I get a chance. If I can reproduce the problem locally then it will be much easier to work out what's going wrong. If not, I'll come back and explain how to debug things further on your machine, but it's not worth putting you through that unless I'm unable to see the problem using the trial version.


#9

To fix this, double-click Opus_SetDllDirectory_Disable.reg registry setting in the attached zip.

Opus_SetDllDirectory.zip (681 Bytes)
Important: After making the registry change, fully exit Opus and then restart it. (Don't just close all the Opus windows. Exit it completely as described in the linked post. If in doubt, reboot after applying the registry file.)

I've tested this with Autodesk Inventor LT 2013 and it made the menus work within Opus.

If you later want to restore things back to normal, use the other reg file in the zip.

The normal mode is more secure, but breaks a handful of 3rd party DLLs. It may make sense to complain to Autodesk that their code requires this unsafe mode to work, especially in software designed for viewing files which is inherently susceptible to binary planting attacks (info at binaryplanting.com).


#10

[quote="leo"]To fix this, double-click Opus_SetDllDirectory_Disable.reg registry setting in the attached zip.

[attachment=0]Opus_SetDllDirectory.zip[/attachment]
Important: After making the registry change, fully exit Opus and then restart it. (Don't just close all the Opus windows. Exit it completely as described in the linked post. If in doubt, reboot after applying the registry file.)

I've tested this with Autodesk Inventor LT 2013 and it made the menus work within Opus.

If you later want to restore things back to normal, use the other reg file in the zip.

The normal mode is more secure, but breaks a handful of 3rd party DLLs. It may make sense to complain to Autodesk that their code requires this unsafe mode to work, especially in software designed for viewing files which is inherently susceptible to binary planting attacks (info at binaryplanting.com).[/quote]

It works very good now. Many thanks for your help. :laughing: