Bug in Define Label Filter?

Hello,

I´ve tryed to use one on the filters shown in the Highlights Video 10.2.
But I got this error-message.
The same on a different computer.

By the way.
Big compliment for your product! Can´t work anymore without it and it´s a great help every day!

regards

Torsten


Does it only happen with the Shell Column clause and none of the others?

If so then it may be triggered by a shell extension crashing when we ask them for the list of their column names.

Which column names do you see if you open Folder Options / Columns and look in the Other category?


Which Column Handler type extensions does ShellExView report?

Hello Leo,

thanks for the fast respond.
First it took a while to find the Folder Options, but on the screenshots you can see, what I have.
Would that be helpful?
I have no "other" category, as you can see.




It's almost certainly the OpenOffice extension, but I'm surprised because in 10.2.0.0 this is blocked in Opus by default.
What version of Opus are you using?

Hello Jon,

my version is 10.2.0.0 as you can see.

Try disabling the OpenOffice extension and see if that makes a difference.

I´ve tryed to disable it, but it crashed again.
Now, after I deinstalled Open Office I can select it, but the second row is empty.

That just means you don't have any shell columns to select from.

same problem for me - I´m trying to setup labels for the perforce columns and opus crashes on selecting "Shellcolumn" from the dropdownmenu.
ShellExView found 3 column handlers: OpenOffice, AutoCAD and Perforce. I disabled the handlers for OpenOffice and AutoCAD and tried again - still crashing (also after reboot).


the columns are showing up correct, also after Opus crashing.

i would love to see that feature working with perforce! :slight_smile:

froyd

It's possible that ShellExView's disable flag isn't working in Opus for Column Handler shell extensions, so the OpenOffice extension is still being used here (and crashing) even when disabled.

We'll look into that, but first we'd like to reproduce the crash you're seeing and make sure it's caused by OpenOffice (and blacklist the extension if it is).

Which version(s) of OpenOffice are you both using? Is it actually OpenOffice itself or the newer LIbreOffice fork (with some extensions still using the old name in the registry)?

Also, what's the GUID that ShellExView reports for the OpenOffice extension? (It'll be in a column you can scroll over to or turn on, or in the Properties page if you right-click it.)

Thanks for the fast response!

Its OpenOffice 3.03.9556, the CLSID is {C52AF81D-F7A0-4AAB-8E87-F80A60CCD396},
but i cant find a GUID - there is no column i could turn on and it doesn´t appear in the properties. I´m using ShellExView v1.76.


I just desinstalled OpenOffice, tried again and now it works like a charm :slight_smile:
Thanks for your efforts, I dont really need OO at the moment, yet it would be nice to be able to use the Opus-labels while having it installed.

froyd

Thanks!

The CLSID is what I was after. (CLSIDs are GUIDs, but it'd help if I used the same term as ShellExView! Sorry about that.) It's also the same as the LibreOffice one which Opus should be blocking automatically. But I had a look at the code and I think I see what's happening...

If you type /dopuslocaldata/State Data into Opus and hit return, you should be in a directory containing shellcolumns.osd.

If you delete shellcolumns.osd, do you still get the crash with OpenOffice installed?

Alright, to answer your question I reinstalled OpenOffice.
The strange thing is, Opus doesnt crash anymore :slight_smile: OpenOffice also installed its ColumnHandler, I checked with ShellExtView, but adding a column-filter for labels in opus doesnt result in a crash now.

Maybe its because Opus with its new feature was installed before OpenOffice in this case, or because I already added some working labels in the meantime - I dont know.

I´m not sure how i can help you now, should I resintall Opus to get the conditions I had before?

You probably won't be able to trigger the problem again unless you happen to have a backup of your old shellcolumns.osd.

Don't worry, I think I've found where the problem was and have fixed it for the next version.

For anyone else still seeing the problem: Please try deleting shellcolumns.osd as described in my previous reply. If that doesn't fix things, post here and (provided you've got a linked account; see my signature) I'll send you a test version with the fix to try.