Bugs still there

  1. Join crash is still there.

=> .When joining files using DOpus, if no path is entered in the Output field (ie: only a name, for ex.: "my_joint_file"), DOpus crashes.

  1. When downloading small (a few bytes long) files from FTP, most of the time the downloaded file is corrupted: it's empty... You need to retry 5-10 times to have a file that's not empty...

It happens on all configs I have tried DOpus on. All have different software/network setups. And on all configs other FTP clients have no problem at all with the same small files.

Leo.

Another problem I already reported for 8.0.x that's still present in 8.1:

.When dropping an unknown file or an executable over a "View" Icon, it usually displays the file in hex mode (and does not load the whole file into memory).

However, it happens that some files which type is not text (ex: iso images) are recognized as text.

=> As a result, DOpus loads the whole file into memory and displays it as text.

It becomes a problem when big files (ie: ~500Mb) are viewed: DOpus will load the entire file into RAM, eating something like 1Gb of swap for a 750Mb file and causing other apps to display an "out of memory" message !

(I just tried to drop a 700Mb zip-packed ISO on my "view" icon, and again DOpus tries to load the entire file...)

Leo.

But why bother? Why would anyone want to drop of 500Mb file on the View icon to view a file that you know you can't view like this?

There must be better things to fill in the time:)

Of course, if Opus cannot recognize the file as anything else then it will drop thnrough to the bottom default plugin and it will treat it as a binary/text file and try to display it the hex display portion of the Viewer. That's what it should do.

_Greg

Hint To view its contents in hexmode ? And why ?

=> To look for a particular string in the binary ? To see the header of an unknown file and rename it correctly ? To find the codec needed for an unknown AVI file (by looking at the AVI header) ? etc...

I guess I won't learn to you the use of an hexadecimal viewer...

The problem is that it seems to recognize some files as text when it's binary... like ZIP packed files, ISOs, whatever...
[/quote]

Leo.