Can a Folder Format use drive alias/label instead of drive letter?

Today I connected my external drive Mike1 but it did not show any of my columns which I knew I had set up. I then realised it was using Drive letter H.
When I looked in Preferences \ Folder \ folder formats they all started with G:????? for Mike1 is there any way of making it automatically save as the Drive Alias /$Mike1 if not is there any way of manually changing it.

Windows assigns always next free letter to a drive. So if you have connected an USB-stick for example and it's assigned to G:, the next connected drive will get H:. Good thing: Windows remembers an assigned letter and will assign it everytime when connected as long it's not used by another drive.

So easy solution: Assign a higher letter to your ext. drive (e.g. X:).

PS: As far I remember it now was possible to assign a drive by label in DO also, but forgot how :-).

You can use a Wildcard Path Format for this.

Create one via Preferences / Folders / Folder Formats, then turn on the Expand Aliases option, and use /$Label at the start of the path.

For example, this will match the Backups folder below my drive with the label SSD:

Thanks for the reply
Mike1 has 4 folders which are set up as follows.
A has Tags column after name
B has Comments column after name
C has File Count column after name
D has only name column
Which were set up when drive was G:
Doing Right Click column heading, Columns then selecting columns.
After putting the columns where I want them and size in lister.
Right Click column heading, More, Save the current folder format.
Which saves as G:\A could this not be changed to save as /$Mike1\A
With the drive as letter G:
Did a Preferences / Folder / Folder Format Wildcard path /$Mike1, Expand Alias
Changed Mike1 to a drive letter H:
All folders now show default columns Name Size Type Modified Attributes.
With Mike1 as G: again
Tried a Wildcard path /$Mike1\A, /$Mike1\B, /$Mike1\C, /$Mike1\D
Changed Mike1 to a drive letter H:
All folders now show default columns Name Size Type Modified Attributes
What am I missing not doing.

Did you clean up the old formats?

What does the format lock on the status bar say when you hover the mouse over it? (Do not click on it, unless it is in the locked position and needs to be unlocked.)

Did you clean up the old formats?
No sure what you mean by clean up.
They are all still listed under Preferences / Folders / Folder Formats / Path Formats
G:\A, G:\B, G:\C, G:\D

For folder A, B, C, D
Hovering over the format lock it says
The current folder format comes from
Default Format
Wildcard path /$Mike1\A
Wildcard path /$Mike1\B
Wildcard path /$Mike1\C
Wildcard path /$Mike1\D

Delete the old formats if you're intending to replace them.

Then edit the new wildcard formats via Preferences and make sure they specify the columns you want.

(Actually, you may want to check the new formats first, then delete the old ones. That way you can copy details from old to new if needed. You can right-click formats in the Preferences list to copy and paste them over each other, without affecting the paths or wildcards they match.)

Thanks it now works as I wanted.

Great program and super support..

1 Like