Can’t find file version ShellProperty


I try to add a column file version. It is useful for fonts file.

So I wrote a script to search for this property. I tried to search via pattern in GetShellPropertyList then via display_name of all properties to no avail.

Here is my test script to search for this property.

var props = DOpus.FSUtil.GetShellPropertyList("*");

DOpus.Output("Available props : " + props.count);

// list available properties matching the pattern
// I tried to search for "version" or "fichier" to no avail.
var re = new RegExp("version", "i");

for (var i = 0; i < props.count; i++) {
	var name = props(i).display_name;
	if (re.test(name)) {
		DOpus.Output("Prop " + i + " :	" + props(i));
		DOpus.Output("			Display name : " + props(i).display_name);

I would expect to see Version du fichier (file version) among the results. I only got this.

Props num : 596

Prop 290 :	System.Document.Version
			Display name : Numéro de version

Prop 382 :	System.Media.CreatorApplicationVersion
			Display name : Version de l’outil

Prop 547 :	System.Software.ProductVersion
			Display name : Version du produit

I’m on last version of Windows 10 (21H1).

What is wrong ? Is someone able to find it ?

I don't think there is a shell property for font versions. The virtual Fonts folder in File Explorer seems to do its own thing, with its own independent list of columns that don't seem to come from shell properties. (It looks like it hasn't been touched since many years before the shell properties system was introduced.)

None of the other font-specific columns the virtual Fonts folder shows in File Explorer have properties either.