Cannot synchronize between local and FTP


I cannot synchronize between local and FTP. Local<->local works fine except empty folders on target are not deleted.

An older version of DirOpus:

I simply set up a directory called "1" with two directories inside, "1" and "2", with 2 identical file, 1.txt and 2.txt. These two files are also outside of dir 1 and 2.
The target folder is empty.

First synchronization works fine

But if I start a second one, expecting no differences are found I get this picture

Files in folder are always affected. One sync deletes them, next copy them and so on.
My settings:

Which version is this with? We fixed a problem in 13.3.1 that could have been related.

I'm using the latest version:

V 13.1, 13.2, 13.3 work fine (but not tested with FTP).

It first appeared in 13.4.

I tested FTP with 13.3. It worked fine. I switched back to this version.

Thanks for that info - problem confirmed, we'll have a fix in the next update.

1 Like

Hi Jon,

Continuing the discussion from Directory Opus 13.4.3 (Beta):

Sync FTP works fine now but first topic still remains:

Please give more detail, e.g. what is the filter you’re using if the problem involves filtering.

My settings:
"Delete destination files that aren't in the source" doesn't work if folder is empty. With content only content will deleted.

This deletes only 2.txt file and leave the three folders empty.


That's different to your original results isn't it?

No, there is no difference. I just tested it with 13.4 and result is the same.

Synchronize is file based (although filters can consider folders/paths when deciding which files to copy across etc.). I don't think it will delete folders in the destination that don't exist in the source; only files, if the corresponding option is on.

(Assuming that's the issue. Not sure if I'm paying attention to the right detail in the screenshots.)

But this worked in older version. I tested it with V11. In V13 there is written "Delete from destination, 1 File, 2 Folders" but the folder are not deleted. The folders counter is also wrong. These are 3 folders to be deleted.


I have to make my answer a little more precise. It worked not only in V11 but also in V13.3 and no longer in V13.4.

I'm trying the SFTP sync feature and I'm reporting the same problem as above. v13.4. I've just synced the folders with WinSCP successfully.

This thread is extremely confusing now, and all the different screenshots aren't helping.

I just re-tested the problem described in the very first post, and as far as I can tell, that's fixed.

If the problem described in the very first post isn't fixed, please provide more information.

If there's a different problem, please start a new thread with information about that.

1 Like

You're right. SFTP sync selects files with same size and modification date

I try to summarize this.

This is my default test setup:

All works fine on local folders AND SFTP:


Syncing failed locally. Folders remain:


AND failed on SFTP totally:


V13.4.3 Beta:
Syncing failed locally. Folders remain:


And on SFTP. Folders remain:


I hope that makes the picture clear. In V13.3 all worked fine for me.

1 Like

I have the same problem. Files AND folders are no longer deleted in the destination. So you can no longer mirror the source with the destination. Orphaned files and folders remain in the destination that do not exist in the source. Even local, not only SFTP.

Ok, please try 13.4.4 and see if it fixes the issue with destination files and folders not being deleted.

It seems to work.