GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Cannot uninstall DOPUS 9


#1

I have just bought version 11 and it says I have to uninstall the previous version first. When I try to uninstall I get this error:
“There was a problem starting C:\Program
The specified module could not be found”



#2

You shouldn’t need to uninstall 9 first.

Have you tried installing 11 over the top of 9? What’s the exact message you’re seeing, and what’s displaying it, that says you need to uninstall first?


#3

Yes, I have tried installing it over the top of 9. It tells me I have to uninstall the previous version first.


#4

As per my last post, this is the error I get trying to install ver 11 over ver 9:


#5

That looks like the installshield data is corrupt.

The first thing I would try is reinstalling Opus 9, in case that works and allows you to run the uninstaller normally. (Opus 9 installer)

If that still doesn’t work, please see Problems installing Opus and try the second last section. (Note that the very last section is only one line, so is easy to miss. I mean the larger one above it which tells you to delete a folder of InstallShield data.)

(The very last part at the end is also worth a try: Verifying that the installer is digitally signed, in case the installer you’re using wasn’t fully downloaded correctly.)


#6

See my comments in bold below

On a 64-bit (x64) system,
In Explorer, double-click My Computer
Double-click Local Disk (C:)
Double-click the Windows folder
Double-click the SysWOW64 folder
Locate the InstallShield folder.
If found, right-click the folder and select Delete

OK - I am left with these which it won’t let me delete even as admin
setupdir
_isdel.exe
_setup.dll
setup.exe

Go back to C:
Double-click the Program Files (x86) folder
Double-click the Installshield Installation Information folder

If you do not see the Installshield Installation Information folder then the folder is hidden:
From the menu bar, select Tools > Folder Options
Click the View tab
Select Show Hidden files and folders
Click OK and then double-click the Installshield Installation Information folder.
Locate the folder ending in BF50D

This folder does not exist, however the folder suggested for 32 bit systems does - so I deleted that

Right-click the folder and select Delete
Close all Web pages and programs
From the desktop, select Start > Run
Enter %TEMP% and click OK
Delete all the files in this temp folder.

[b]Done, rebooted, tried to uninstall ver 9.
No joy though - exactly the same as before.

The digital signature is OK
[/b]


#7

Sorry - I forgot to say - I tried installing ver 9 again (which it did) but it didn’t help.


#8

Did you use some sort of migration tool to move your programs from 32 to 64 bit? That could have caused this sort of problem.


#9

No, I just installed it.


#10

More problems I’m afraid. FTP no longer works properly now, I can copy files down from the server to my computer, but not folders. This was not the case before I tried uninstalling ver 9.
I am going to try this
support.microsoft.com/mats/progr … install/en


#11

The 32-bit installer shouldn’t have let you run it on 64-bit Windows, unless the installer exe had been manually set into Compatibility Mode (where Windows would pretend it was a different version when running the installer; that could cause problems).

(We’ve also seen unofficial installers made by other people who have “re-packed” our software in their own installers which also carry spyware or similar as part of the payload. Those are outside our control, of course.)

Something strange has definitely happened and messed things up. Unfortunately, it’s difficult to know what. We haven’t had any similar reports over the years so it may be unique to your machine.

Have any other installers/uninstallers had any strange problems?


#12

OK - microsoft fixit didn’t work. It just asks for a 38 character product code which I don’t have.

What does work is to go here: revouninstaller.com/download … ersion.php

Use that to uninstall ver 9, then install ver 11.

I used the original installer I downloaded when I bought ver 9 and I didn’t manually set it into Compatibility Mode. No problems with any other uninstallers.

So now I just have to fix the FTP problem, if I try to drag a folder down from an FTP site nothing happens. Files work fine. I will look through the forums and post a new thread if I can’t find the answer.


#13

Thanks for your help on this one BTW :slight_smile: