Can't connect to NAS as it is using SMB1

I can't connect to my new nas fron DO. When I do \\mynas I get a message saying that I am using smb1 and as it is unsafe I should use smb2. How can I do this?

My fault. I looked at the NAS settings and it was only set to SMB1. Having set it to accept SMB2 it works.

This is down to the configuration of your NAS and Windows, and not related to Opus. You'll see the same result in all programs.