Can't find gvim when invoking context menu on a file

I recently upgraded from gVim 7.2 to gVim 8.2. "Edit with gVim" still appears in the context menu for a file but when I choose it I get an error pop-up saying "Windows cannot find 'C:\Program Files (x86)\Vim\vim72\gvim.exe'. (Invoking gVim from the context menu in Windows Explorer works fine.)

I have turned on context_menu_debug. In DebugView I see: [8964] [1168] dopus: CLSID: {51EEE242-AD87-11d3-9C1E-0090278BBD99} (Vim Shell Extension) (C:\Program Files (x86)\Vim\vim82\GvimExt64\gvimext.dll). There is no other mention of vim.

I am at a bit of a loss...

Try using regedit to find the wrong path in the registry and correct it. Gvim must not have updated all of its registry entries correctly, unless it’s something you added yourself to your Opus context menus.

Many thanks Leo. I've searched the registery and found several dozen references to the old version of gVim, which I've corrected. But the problem persists.

I may very well have added it to the Opus context menu myself but it would have been (many) years ago and I have no memory of how that is done. Where should I be looking?

Settings > File Types is the most likely place.

Thank you Leo; your hint was what I needed.

For the record, I chose Settings > File Types as instructed. I then highlighted "All files" and clicked the "Edit" button at the bottom of the window. In the window that opened I clicked on the "Context Menu" tab where the offending reference to vim72 appeared. I highlighted it then clicked the "Delete" button.

Thanks again for the very prompt assistance Leo, on a sunday yet.

1 Like