Can't get button icons to not show

I keep having the "show icon" box left unticked, but icons won't go away.

Did I change something in Advanced that would cause this?

You may also have to check show label. You can also select a blank icon when you choose an icon.

The icon state can be overridden for the whole toolbar by the options on the Customize dialog.