Can't install Opus 12 on Win 10: error 0x8000FFFF

Thanks for the new logs.

The symptoms seem to be the same: The installer works normally until it's time to run an .exe file, then instead of running it it aborts.

I thought of something to try:

  • Open a command prompt, and CD to where the installer is.
  • Run DOpusInstall.exe /extract_all:"OpusInstall" to extract the installer contents to an OpusInstall subdir.
  • Copy (copy, don't move; that could be important) the OpusInstall dir into C:\Users\<username>\AppData\Local\Temp
  • Go there and double-click the Setup.exe.

Does the Setup.exe launch OK from there? And can it then get further than it did originally?

Hi Leo,

Thanks for your advise. I'll give it a try and report what has happened!
See you tomorrow (it's 0:45 AM in Germany, so I gonna get to sleep...)

Hi Leo,

bad news: Setup has aborted again -- same game as before :unamused:
As recommended, I copied manually extracted setup file folder to my User temp folder and started from there, not using Uninstall Tool.
[Same result when installing from another folder (after copying, not moving files there)].

Hm... it's really crazy...
Yesterday I installed another 64-bit software without any problems. Same success with Microsoft Office and many more programs.
Must be a weird bug in Opus installer -- or an odd combination of things (Installer can't deal with my Windows settings; or an installed Windows update blocks something?).
Did you receive similar support requests with this issue? There should be many clients using latest Windows 10 build, having the same effects...

Like before, I'll send you Process Monitor logs.
Additionally, the log of Uninstall Tool showing files Opus installer created during installation.

Remark: Surprisingly, folder C:\Program Files\GPSoftware\Directory Opus is empty after installation terminates. Again, I had to force setup to use this folder, not C:\Program Files (x86)\GPSoftware\Directory Opus.

Kind regards
Workaholic

In case this may help:
I encountered the exact same problem ("catastrophic error" and all that). I couldn't install 12.11. (Tried tweaking public desktop folder permissions etc and it didn't help) So I deleted my dopus folder and went to the page for 12.10 (by googling "dopus 12.10") and downloaded it. And it installed without any problems. Then I found out (by checking the version number etc) that what I ended up installing is actually 12.11. What's going on? Well, in my download folder there are two installers. They are of the same size (54.7MB). Why does one install and the other doesn't? It turns out the only difference is this...

In other words, the file that successfully installed came with the compatibility mode (for win7) checked. Then I remembered that, when a couple of months ago I downloaded dopus trial and tried to install and couldn't, this was the exact setting I tweaked which allowed me to install it. My windows version is 10 (1809).

Hi porpoise!

Thanks for your interesting post. Glad to hear that I'm not the only one... Got the same Windows 10 build (1809).
I didn't test your solution yet. First of all, I've got some questions about it:

(1) Did I get you right that the Opus 12.10 installer contains Opus 12.11 in fact? Sounds really odd... together with the fact that both files have (exact?) equal size.
(2) In 12.10 file properties, the compatibilty checkbox was already activated by GP Software?!?
(3) Is it possible to install 12.10 version without marking that checkbox? (I don't want to run Opus in compatibility mode and the support team told me not to do).
(4) Did you have the same problem that Opus 12.11 proposes wrong installation folder (despite 64-bit OS)? The same with 12.10 installer?

Might be a hidden bug in 12.11 installer, as supposed in my last post. Or one of these mystic faults caused by Windows 10 October Release (according trade press, there are a plenty of them).

Kind regards
Workaholic

Hi Workaholic, that's what I downloaded from this page (Directory Opus 12.10). I was expecting it to be an 12.10 installer, but it turned out (I think) to be 12.11. In fact, I just checked and the download url on both the page for 12.11 and 12.10 are the same, so I guess they always point to the latest version. Hmm. I'm not sure what's going on. Anyway, I initially downloaded 12.11 via "Check for update", so that could be where I got the file with the unchecked compatibiliy box from.

Anyway, re: (2), yes absolutely, one of the two files came with the compatbility boxes checked. That's the one that ended up installing.

Re: (3), on my machine at least, I've never succeeded in installing dopus without having the compatibility checkbox checked. I should also clarify that, although I installed dopus in compatibility mode, it (dopus.exe) does not run in compatibility mode. The app runs just fine after installation.

Re: (4), no, I have not had that problem. It's always "Program Files" and not the other one.

None of the compatibility settings should be needed, and if they get applied to the program itself they could cause the wrong Explorer Replacement method to be used.

If a previous install was done with compatibility settings on, it could cause later updates to only work if the same settings are on, which might be what has happened. We strongly recommend never turning them on, at least on a working system.

If things are working then I guess it's worth a try, but something somewhere is messed up on the system if they are needed or if the installer thinks it should put the program in the 32-bit program files folder.

We have another workaround to try which I'll send shortly (a way to install the update without using InstallShield), but at this point I think something is wrong with the Windows install for these problems to be happening. We don't have any other similar reports, and thousands of other people are using the installer without (reported) issues.

(In the longer term, we are also probably going to ditch InstallShield as it is so opaque at times when there are problems.)

That makes sense. It could be what happened in my case.

I'm not sure what is it about my original OS that made turning on compatibility mode when installing necessary. But I do a lot of tweakings of my windows (registry, group policy, services ... I also moved the location of my desktop & downloads folder. Also, I'm a big user of hardlinks, many of my files have 2 or 3 reference counts - that's often been a source of problem for apps), so I'm accustomed to apps failing to install/run because of some settings aren't as they assumed them to be. No complaints on my end.

(Anyway, fwiw I tried to install the update multiple times. Everytime it fails, I would still be able to run dopus.exe to launch dopus 12.10. Until I attempted (a couple hours ago) to install the update again, and this time the error proved genuinley "catastrophic" (lol), since I was no longer able to run dopus because the program says (irrc) "couldn't find the english language pack" and exits upon launch. That led me to try and download 12.10 and finally solved the problem by luck)

Hi Porpoise, Hi Leo,
thanks for your discussion with its helpful hints.

@Leo:
Of course it's possible that's something wrong with my Windows. Not very likely, because it's a pretty fresh Windows without any sensitive user modifications or many other installations. And, as mentioned, I was able to install other x64 programs using InstallShield without such issues.
So it keeps mysterious. Maybe everything works perfectly when you install Opus on older Windows 10 builds (e.g. 1803) and update Windows later on to 1809.
Can you confirm Porpoise's statement that Opus 12.10 and 12.11 setup files are equal?

I'm looking forward to your workaround (thanks in advance!) and will stay tuned...

As Porpoise said, the URLs he used for both downloads are literally the same.

I wouldn't say your Windows install is in a fresh state as it has a lot of things installed on it, including one thing whose entire purpose is to monitor and modify how (un)installers behave. :slight_smile:

No issues here running the installer on Win10 1809, both a fresh install and an upgrade from 1803. Whatever is happening is quite strange, especially combined with the wrongly detected program files dir.

Believe me or not:
Finally, I made it work. Directory Opus 12.11 x64 is running!!! :ok_man:

What happened?
After many, many attempts and uncounted hours of researching & testing...
(I even was close to get back to my old software solution. :disappointed:)

I tried Porpoise's workaround, used the archived Opus 12.10 setup (which is 12.11 in fact), started installation... and It ran through to the end -- as if nothing had ever happened before.
(The wonder was logged by Uninstall Tool).

To me, it's obvious that there must be something wrong with the "official" 12.11 installer, which failed dozens of times. The "older" 12.10 version succeeded at the very first time!

@Porpoise: Thanks a lot for your perfect tip! :grinning::+1:

Here's the proof.
Zwischenablagebild

They're exactly the same file.

1 Like

...obviously not?

You could have a look at their checksums to know for sure, but the only way you could have 12.11 installed is if you used the 12.11 installer and there's only one version of that that we've released. The link in the "new version" posts always downloads the current version, not what was current at the time it was posted.

Jon, I took the 12.10 link instead of "new version".
I agree with you that these two setup files are apparently the same.
Nevertheless, the result is completely different. I'm not kidding!
As you can see in my screenshot, latest 12.11 version has been installed, though it should be older 12.10 version.
It is not explainable at all and even a little bit spooky...

Anyway, I'm glad that Porpoise's note worked perfectly after three days of frustrating trial & error.

Workaholic

There's definitely something up with your system if the older installer worked, then the newer one didn't work for a few days, but then started working again yesterday. (On top of the 32-bit program files issue.)

Maybe something that was causing the problem was updated and no longer is.

FWIW, yesterday I tried Uninstall Tool on a machine myself and, while I didn't see either problem, I did confirm that it wraps installers in some way and traces processes that they start, and that it also misidentifies Opus as being a 32-bit application. It could be completely innocent, but it still seems a potential cause of either or both issues.

Hi Leo,

thanks for further testing, even with Uninstall Tool.

You're right: Sometimes Uninstall Tool lists 64-bit applications as 32-bit. The reason for this is unclear. As far as I can overlook it, the concerned apps have been installed in the correct folder. So it's probably more of a bug than a real problem.

The 32-bit program files issue didn't appear during my last, successful attempt. (I didn't mention that point in my "Halleluja! post" :wink:). The same with your installation?

The only remarkable difference between all these aborted installations in the past and the happy last one is, that Windows had been installed several new updates. First I was optimistic that these updates maybe could solve my problem. So I tried again to install after updating and restarting Windows. But the result was the very same...

I know, it sounds crazy in your ears, but the solution has been brought by 12.10 installer -- and nothing else.

Workaholic

One last question:
Can I truly find out within Opus, if the program runs 32- or 64-bit mode? Info dialog reports "64-bit" (see screenshot above).

You didn't download a 12.10 installer, did you?

If you look at the URLs on the new release posts, they are literally the same for every release. They always point to the latest installer (which we replace).

They don't just point to a different copy of the same file; they are the same URL and literally point to the same file. The URL never changes.

Now that 12.11 is out, if you go back to the 12.10 announcement and click the download link, you download 12.11, using the exact same URL as when you click the same link on the 12.11 announcement.

Leo, I used this installer:
https://resource.dopus.com/t/directory-opus-12-10/30069

The description suggests a "real" 12.10 installer.

As we keep saying, the download URL there is:

https://www.gpsoft.com.au/DScripts/download.asp?id=60

If you look at the 12.11 or any other non-beta release post, the download URL is:

https://www.gpsoft.com.au/DScripts/download.asp?id=60

It's the same URL.

There is only one version of the 12.11 installer. There isn't a time travelling "12.10" version of the 12.11 installer. :slight_smile: You just downloaed the 12.11 installer again and it worked this time, due to changes elsewhere on the system, or maybe due to how it was downloaded (e.g. downloading to a different folder might mean some hidden compatibility setting Windows was applying was not applied to the new download).