GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Can't install Opus 12 on Win 10: error 0x8000FFFF


#62

Jon, I took the 12.10 link instead of "new version".
I agree with you that these two setup files are apparently the same.
Nevertheless, the result is completely different. I'm not kidding!
As you can see in my screenshot, latest 12.11 version has been installed, though it should be older 12.10 version.
It is not explainable at all and even a little bit spooky...

Anyway, I'm glad that Porpoise's note worked perfectly after three days of frustrating trial & error.

Workaholic


#63

There's definitely something up with your system if the older installer worked, then the newer one didn't work for a few days, but then started working again yesterday. (On top of the 32-bit program files issue.)

Maybe something that was causing the problem was updated and no longer is.

FWIW, yesterday I tried Uninstall Tool on a machine myself and, while I didn't see either problem, I did confirm that it wraps installers in some way and traces processes that they start, and that it also misidentifies Opus as being a 32-bit application. It could be completely innocent, but it still seems a potential cause of either or both issues.


#64

Hi Leo,

thanks for further testing, even with Uninstall Tool.

You're right: Sometimes Uninstall Tool lists 64-bit applications as 32-bit. The reason for this is unclear. As far as I can overlook it, the concerned apps have been installed in the correct folder. So it's probably more of a bug than a real problem.

The 32-bit program files issue didn't appear during my last, successful attempt. (I didn't mention that point in my "Halleluja! post" :wink:). The same with your installation?

The only remarkable difference between all these aborted installations in the past and the happy last one is, that Windows had been installed several new updates. First I was optimistic that these updates maybe could solve my problem. So I tried again to install after updating and restarting Windows. But the result was the very same...

I know, it sounds crazy in your ears, but the solution has been brought by 12.10 installer -- and nothing else.

Workaholic

One last question:
Can I truly find out within Opus, if the program runs 32- or 64-bit mode? Info dialog reports "64-bit" (see screenshot above).


#65

You didn't download a 12.10 installer, did you?

If you look at the URLs on the new release posts, they are literally the same for every release. They always point to the latest installer (which we replace).

They don't just point to a different copy of the same file; they are the same URL and literally point to the same file. The URL never changes.

Now that 12.11 is out, if you go back to the 12.10 announcement and click the download link, you download 12.11, using the exact same URL as when you click the same link on the 12.11 announcement.


#66

Leo, I used this installer:
https://resource.dopus.com/t/directory-opus-12-10/30069

The description suggests a "real" 12.10 installer.


#67

As we keep saying, the download URL there is:

https://www.gpsoft.com.au/DScripts/download.asp?id=60

If you look at the 12.11 or any other non-beta release post, the download URL is:

https://www.gpsoft.com.au/DScripts/download.asp?id=60

It's the same URL.

There is only one version of the 12.11 installer. There isn't a time travelling "12.10" version of the 12.11 installer. :slight_smile: You just downloaed the 12.11 installer again and it worked this time, due to changes elsewhere on the system, or maybe due to how it was downloaded (e.g. downloading to a different folder might mean some hidden compatibility setting Windows was applying was not applied to the new download).


#68

...ok, I believe (and finally, I mentioned it myself) that both installers are completely equal. And most certainly you're right that other circumstances led to final installation success. Maybe it was pure coincidence... we'll probably never find out what really happened.

Despite your comments, I was just irritated about the fact that undoubted there is a 12.10 download link but it leads to actual 12.11 version. You have to know that... :pensive:

Thanks again everybody for your patient support!
Workaholic