Can't see files - FTP problems

Why can't I see files in an FTP folder I logged into? The files ends with the format "edi" if this matters. When I try via the command prompt is works fine so I know the files are there. Maybe a preferences issue but after spending an hour on trying to search for trouble shoot or likewise in D.O. on this issue I got tired. How hard could it be?

Are they flagged as hidden or hidden+system files?

Toggle display of Hidden / System files

No, they are not but a note, I do find txt files, so far it seems only to be once with the ending ".edi" that is giving me a headache

Near the top-right of the default toolbars: Folder > Folder Options, then to the Filter tab. Is anything set to be hidden there?

What about under Settings > Preferences / Folders / Global Filters?

No, it's default settings used (no filter activated)
In the Settings >Preferences / Folders / Global Filters the configuration was set to "Hide system files". I unmarked this and saved but without any effect (I still do not see the files on the FTP outbox folder) I'm afraid

Does the status bar indicate anything is being hidden? It should say "4 Hidden" or similar (depending on status bar settings).

If you hover over the hidden count, a tooltip should appear listing some of the hidden items. Does it include the .edi files?

No, it isn't. It's only shows "0/0 0/0 0 bytes / 0 bytes.

Note, I'll checked this on other local drivers and here I get "1 hidden" etc but on the FTP there is nothing

When you connected using a command-line client, which command did you use to list the folder?

Opus will normally use MLST by default. Check that command on the site lists the missing files, and that there's nothing unusual about the output for them vs other files.

You can change the command Opus uses via the FTP Address Book, Misc tab when editing the site. The MLST and LIST options are the two relevant ones.

If there's a way we could get a login to the site to investigate, we could check in more detail. (Of course, don't post the details to the forum.)

Hi Leo,
My command after being logged in was "cd /outbox" and then I list the folder by using "ls". This morning I tested to add "ls" in the "Use custom LIST command" and then logged in to the FTP but again, no files found. Is it possible for us having a conf call where I can share my site/computer? I can send a invitation via Skype if you like where I have possibility to share and give you control over my pc.

So with ls everything was missing, not just the edi files as before?

What happens if you try LIST -alF and LIST on its own? (Please try with MLST also turned off in both cases.)

Remote access to the client-side PC probably wouldn't get us far so it's probably not worth setting that up. Ideally we'd be able to connect to the server side so we could look at things under our debug tools, but it's understandable if that isn't possible. We may need to send you a test version that logs extra information to diagnose what's going on.

Before we try that, and assuming the list command suggestions above to not help, could you do the command line test using ls, LIST -alF and LIST on its own, and paste some of the results here (please include at least one edi file and one non-edi file so we can try to spot any differences). That would be the first test we would run if we could access the server, and it could be enough to tell what's happening.

If there's anything sensitive in the results that you don't want to post to the forum, you can email them to if it would be better.

Hi Leo,
Sorry for late reply. However, yes, when using "ls" in Opus / FTP / MISC settings I got the very same result as before - can't see any files. I have today also tried with MLST turned off (only using "ls" as "Use custom LIST command" but still no happy ending I'm afraid. I'll send you an email with some more details and let's take it from there. :slight_smile:

Thanks for emailing the details so we could try at our end.

I found no directory listing came back at first, but things seem to work find if I turn on Use custom LIST command and set the command to LIST on its own.

That should be all you need to do.

Looking at the server log shows the FTP server does not seem to understand extra switches given to the list command. LIST -alF is used by default:

--> LIST -alF 125 Data connection already open; transfer starting. 8 bytes received in 0.94 seconds (0.0 Kbytes/sec) 226 Closing data connection, ASCII transfer complete.

Only 8 bytes come back, which is not a directory listing. It probably thinks it has been asked to list a folder called "-alF" or something.

LIST on its own has better results:

--> LIST 125 Data connection already open; transfer starting. 125 bytes received in 0.453 seconds (0.0 Kbytes/sec)

Hi Leo,
Yes, that fixed the problem. Really nice. Thanks a lot. I'll appreciate it very much. Have a great weekend :slight_smile: