Can't send to desktop as shortcut - no UAC?


I am defeated. Windows 10 x64 Version 1809.17763.316, Opus version 12.11 x64 (tried 12.12 x64 and Beta, same condition).

Here is my story:
New fast computer, install Opus. Go to a directory in Opus right click on a program file -> send to -> desktop as shortcut, no UAC prompt but error:

brand new disk, it is not full.

So I create a shortcut in the programs directory and try to copy it to the desktop, no UAC but error:

Even though the shortcut is copied to the desktop! And the shortcut works.

If I try to right-click drag the exe to create a shortcut on the desktop:

So I have tried re-install, rebooting numerous times, recreate the Windows profile, check all the security in the folders. File Explorer can create the shortcuts just fine.

I am not sure why Opus is not asking for UAC when trying to send to the desktop as a shortcut. Tried elevating Opus to admin, no luck. Tried turning UAC off, rebooting, no luck.

So I am hoping someone can come up with a miracle. I have already spent over three hours on trying to get this to work.

I have been an IT professional for over 20 years and have used Opus since version 8 and have never seen this issue.

I have even tried to copy over a working Opus from my old computer but run into the same issue. Tried creating a button to -> Copy MAKELINK TO=/desktop, same error, disk is full.

Please help me see what I am doing wrong. Too many settings in the registry for me see if that is what it is so I am hoping for a miracle.

Funny - when I go to delete the shortcut in the program folder I get the UAC prompt.

When I try to rename the shortcut on the desktop with Opus I get the UAC prompt then Access is denied. File Explorer renamed it fine.

NETGURU - Terry D. McPeck

That is odd. It works as you'd expect when I try the same things here.

It's possible antivirus is blocking the operation when it's done by Opus but not Explorer.

Using Process Monitor to see what is happening may be the best option: Process Monitor instructions

(Please link your account if you'd like us to look through Process Monitor logs.)

Bleeping Microsoft

Turned this off and the send to desktop as shortcut worked:

That was using Windows Security, off that goes! Other items started to work also like saving the snippets to the My Pictures directory.

I'll have to investigate that further but that is very rude of Microsoft for sure. I usually use CryptoPrevent by FoolishIT but have not got around to installing.

Wanted to post this in case others have weird issue with this version of Windows.

I think we can call this case closed.

Thanks Leo for the hint about AV.

Terry D. McPeck

1 Like

Glad you got it working!

I'm a firm believer that if a security tool blocks something it should tell you immediately. If it's a real attack, you need to know and take precautions against aspects of it the tool may not have found. If it's a false positive, you need to know to avoid wasting time troubleshooting weird problems. Security tools that silently break things are terrible!