GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Checkbox matching the full path

Today I found out that 12.14 has added checkboxes to match the full path in Simple wildcard and regex labels. However, at 12.14, this check box does not work. Press the OK button after selecting and the selection will disappear. Open the dialog again, the checkbox is unselected; 12.14.1, 12.14.2 does not have this checkbox.

Will the stable version be added back?

Thanks!

I think there's some confusion here. The checkbox didn't exist in 12.14 and was added in 12.14.1:

  • Simple wildcard and regex labels now have a checkbox to specify whether the pattern needs to match the full path or just the file or folder name. If you're just testing an extension like *.doc then it doesn't matter, but this makes it easier to, say, highlight files with names matching FW*.doc.

It's still there in 12.14.2:

I checked with Opus switched to Chinese as well, just in case, and it's there as well. Since it's a beta version, some of the strings are still in English, but that will change in 12.15 with the updated translations:

If you're using the special language DLL Greg sent you for testing a day or two ago, that might be a factor.

1 Like

Thanks Leo, you are too smart. I understand that this is the reason. So it just exists and doesn't work, I am confused for a while.

However, it does not exist in 12.14.1, 12.14.2.


I now know that wildcards are much more efficient than filters if a lot of tags are added.

Just like *.doc, FW*.doc can be used without this checkbox, and the result can be the same. Their functions should be the same, no one would have thought thatFW*.doc could not mark any one file. If you add *\ to the front of each wildcard inside the program, this checkbox can be unneeded.

This will reduce the chance of error and simplify the programming.

When using the DLL Greg sent you, or not?

No.

I copied the DLL Greg sent me, the checkbox appears, but it doesn't work.

When you say it doesn't work, what do you mean exactly?

The "($F)(F)" on the end looks unusual. Or is that normal for some control labels in Chinese?

I mean the corresponding file still can't be marked as before.

I found the reason, canceled the checkbox selection and worked.

It should be reversed.

I am also wondering what it is, I have not seen these labels before.

What's the wildcard that you are using, and what is the full path of the thing you are trying to match against?

What result do you see with the checkbox on, and what do you see with it off?

Don't forget to Apply the main Preferences dialog after making changes. Nothing happens until you do that.

The wildcard is FW*.doc and the full path is d:\files.

Checkbox on, nothing; checkbox off, the result I want.

I confirmed that I clicked Apply or OK, I did it again and the results were the same.

A folder with the full path of D:\files will not be matched by a wildcard of FW*.doc whether you're testing the full path (D:\files) or just the name (files).

Do you mean a file within that folder? If so, what is the full path of the file? e.g. D:\files\FWxyz.doc or similar.)

Checkbox on, nothing; checkbox off, the result I want.

Please be clearer. What is "the result I want"?

Sorry, D:\files is a folder and I forgot to write the name of the file. The full path is D:\files\FWxxx.doc (a lot of files).

The result is that the doc file at the beginning of the FW is marked in red.

That's what should happen.

FW*.doc will match the file name FWxxx.doc.

If "Match Full Path" is off, it will match the file:

FW*.doc will not match the full path D:\files\FWxxx.doc.

If "Match Full Path" is on, it will not match the file:

It's working correctly.

1 Like

Oh, I understand it wrong. I always thought that "Match Full Path" is on, which is equivalent to typing *\FW*.doc.

I am very much looking forward to 12.15.