GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Compatibility Issue of DO with Dragon Naturally Speaking > high CPU load

Directory Opus 12.6 does somhow interact with Dragon Naturally Speaking:
As soon as both applications are running, the computer gets very slow because Dragon, Directory Opus and the system process all generate high CPU load even when idle. Within the system process, it is the acpi.sys-thread that causes the high CPU load. If you reboot and do not start Directory Opus again, everything works fine, and Dragon works smoothly in all the many applications that I use. The issue is reproducible and usually starts after a few minutes of dictation with Dragon. Do you have any idea how this could be fixed?
It makes DO unusable for me, which is really a pity, since I have been using it for many years and it's just excellent.

This thread suggests Dragon Naturally Speaking may cause high CPU usage if it's picking up and trying to process a lot of background noise.

Could something you're doing in Opus be causing more noise than there was before? (e.g. Noisy disks being used more than usual near the microphone, or playing audio/video files?)

Opus doesn't have any direct knowledge of or interaction with Dragon Naturally Speaking, while Dragon will inherently have to hook into Opus and every other program, so whatever is going on is more likely to be in Dragon's court rather than ours (although anything is possible, of course).

You could try generating some process snapshot dumps of the processes with high CPU usage when it happens and send them to us:


While it's happening, please go to Task Manager, then the Details tab, right-click dopus.exe (or the affected process) and select Create Dump File.

Do that 4 or 5 times, and it should create something like:

C:\Users\<username>\AppData\Local\Temp\dopus.DMP
C:\Users\<username>\AppData\Local\Temp\dopus (2).DMP
C:\Users\<username>\AppData\Local\Temp\dopus (3).DMP
C:\Users\<username>\AppData\Local\Temp\dopus (4).DMP
C:\Users\<username>\AppData\Local\Temp\dopus (5).DMP

The files will be large, but compress well.

If sending more than one file, using the 7z format instead of zip will give a much reduced size. You can do this via the Archive Files button in Opus.

Please zip or 7z the files and email them to crashdumps@gpsoft.com.au (it's best not to post full dumps publicly to the forum).


Note that it may take a few days for us to look at them at the moment.

Those snapshots may let us point to a more specific/likely cause, but my guess is that you'll need to talk to the Dragon developers as well as it is not likely the issue is with Opus, unless it's something that Dragon is not involved in at all and happening entirely within Opus (in which case the FAQs on high CPU usage when viewing certain folders and when right-clicking certain files as the best places to start).

Thank you very much for your immediate reply. My explanation was not precise enough: The high CPU load issue appears not only when Dragon is listening, but also with the microphone turned off. So there should be no noise-related issue. In fact it looks like the combination of DO and Dragon makes the acpi.sys process crash and then continue to create cpu load.
This might in fact be some driver related issue. I will further look into this and test on a freshly installed PC and then get back to you with more precise information / screenshots / crash dumps if the problem persists.

1 Like

The issue disappeared with one of the recent updates for Windows 10.
In my view, this thread can therefore be closed.