Contents of directory junctions not automatically refreshed

I have a 4NT script which maps some Truecrypt containers as drive letters and creates necessary junction points (with mklnk M:\ D:\MyDocs; 4NT calls it as "soft links" aka "directory junctions" or "reparse points" though Microsoft's terminology may differ), so that I can use e.g. D:\MyDocs as before the migration, though the real contents are on [i]M:[/i].

This works perfectly, but DOpus unfortunately does not refresh the contents automatically nor it calculates the dir-size if hovered with mouse. I've activated File Operations -> Options -> Detect external file changes on network drives, to no avail.

Is this a bug or is there a setting for this that I don't know of?

Opus 8 or Opus 9?

Oh, I forgot to mention that. It's, the latest (still smoking :slight_smile:

Junctions (etc.) should work in Opus 9 but maybe something's going wrong due to this combination of junctions and Truecrypt containers.

I'll see if I can reproduce the problem here.

When you mount the Truecrypt container which settings do you use:

NTFS or FAT format?

You might also be able to unearth some useful information by following the debug steps in this FAQ:

[Changes to folders are not being detected)

Let us know what you find and I'll try to take a look at this on my machine as well.

I've tried these:

  • If I create junctions, linked to folders on the same drive notification does work.
  • Notifications in junctions pointing to external USB harddisks do work too.
  • Notifications in junctions linked to USB sticks do not work; I've tried it with both FAT and FAT32-formatted sticks. So it's not Truecrypt only.

FWIW, all USB HDD and sticks are "optimized for quick removal".

Removable and NTFS, no readonly. I think the evil keyword here might be removable.

Nice FAQ, but it didn't help me much. Debug window shows nothing, no matter what I do. Maybe it's something to do with me having no admin rights^WCorrection: debug_notify doesn't work with admin rights neither.

I'm having similar problems with a TrueCrypt volume: When dragging and dropping between windows, I have to refresh both windows for the changes to be registered. The volume is mounted on my HDD in the conventional way. Files on the parent (C:) drive volume refresh automatically.

The problem's fixed in version

Doesn't mean the particular problem cyilmaz was having with junctions and Truecrypt and useb is resolved tho...

Quite right -- sorry. I was totally focussed on my own problems :frowning: