GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Context menu in DO on the Desktop folder, Vista Question

I made a context menu for UltraEdit and when I was viewing the Desktop folder (that is, the very top of the tree) in DO, the menu option did not show up. But, when I go to c:\users\skip\Desktop, the context menu works. This is on Vista Premium, 64 bit. Is this a normal Vista-ism and I should just learn to deal wit it or am I missing something simple?

Btw, the is DO 9.1

If you're viewing the virtual Desktop (/Desktop, the merged view of C:\users\skip\Desktop, C:\Users\Public\Desktop and some other icons like Recycle Bin) in Opus then the view is provided by Explorer. Any Opus-only context menu items will be missing in that case.

If you instead view the Desktop folder in your profile (/DesktopDir, C:\users\skip\Desktop) then Opus does everything and you'll see the items.

If the context menu item just runs UltraEdit with the selected filename then you can have it in both places. I think you'll need to delete the existing context menu item and then create a new one. Make sure you set the Type drop-down to Run an application (supported in Opus and Explorer)

Note: For some reason you can only add Opus-specific items to the All Files type. Maybe Explorer doesn't have the "All files (and not folders)" concept. This restriction isn't there for the All files and folders and the All folders types, nor for normal file types like .txt and so on.

When you say "set type to drop-down", did you mean "drop menu"? That really isn't what I want to do. That's for dragging and dropping items into listers, correct?It's kinda awkward to have to RMB drag the icon just a bit enough to get the menu to pop up.

This is not a big deal, if it can't be done. I'll just remember to go to the /DesktopDir vice /Desktop.

No, the Type drop-down, i.e. the drop-down called Type. Set that to Run an application. Here's a picture:


Hmmm... your screen shots and options for the drop downs are slightly different than mine. I am using ver 9.1.0.6.3044 x64.

Skip


You're editing the All Files type. See the note I wrote above:

Of course I knew that. I was just testing you! :slight_smile:
It worked, but would you believe the only strange thing is the icon does not show up in the menu when using the context menu on the /desktop. That and the fact that for /desktopdir the menu item is at the very bottom of the context menu, but on /desktop it is fourth from the top. sigh

Thanks for your help, Leo. And I promise to pay more attention to your answers in the future so you won't have to answer me twice.

Both those things are normal. If you create a context menu item in Opus then the icon (if any) only shows up in Opus's menus with just text in Explorer-generated menus.

Explorer also doesn't provide any way to define the order of menu items; instead they seem to get added in the order it finds them in the registry, resulting in a big mess. You can tidy up this mess in Opus with a bit of work (see here) but not in Explorer.