Control Panel and Explorer replacement mode

I'm evaluating latest version of DO with intention to upgrade to it from the 9.5.x version. Note that I did a clean install of DO 10 this time - i.e. I did uninstall version 9, installed version 10 and didn't import old configuration. The problem is that the Control Panel stopped working for me when the Explorer replacement mode is on. If I turn it off I can start Control Panel via Start Menu option I can use Desktop context menu to go to Customize applet and I can use system tray context menu to go to icon hiding dialog. When the explorer replacement mode is switched on again I can't do anything of these. Note that everyting else seems to be working as expected in this mode - every time I expect Explorer to be luanched by other application DO is starting with the correct folder loaded.

Do you see any error message, or anything at all, when you try to open Control Panel?

Which of the Explorer Replacement modes are you selecting?

Which version of Opus 10 are you using? Older than 10.2?

If UAC is enabled, make sure dopus.exe is running as a normal process, not elevated.

I don't get any error messages, nothing really happens when trying to access Control Panel main dialog or its applets by different ways as described before.

I'm using the following option (note that the exact names can be a bit different since I'm using Polish version and translating all the options back to English): Settings > Preferences > Starting Opus > Replace Explorer for every file system folders (recommended). This is the same option I've been using with DO9 without any problems. I've also tried "Replace Explorer for all folders" and "Replace Explorer for all folders excluding the following". Same effect. I can get to Control Panel only if "Do not replace Explorer" is selected.

I'm using version (build 4645) Pro 32-bit under Windows 7 Pro 32-bit.

UAC is enabled and working fine. I can turn on administration mode inside DO, and after elevation prompt all programs started inside DO will run elevated. Checked with Process Explorer to be sure. No, dopus.exe itself is not running elevated. Checked with PE too and also to be 100 % sure I've also checked EXE file properties dialog inside Explorer.

Thanks, that sounds like everything is set up correctly.

As an experiment:

[ul][li]Create a new folder on your desktop.[/li]
[li]In the Explorer Replacement settings, choose Replace Explorer for all but the following folders.[/li]
[li]Drag the folder you created into the list below that setting, so it is added to the list of exclusions.[/li]
[li]Apply the change, and close any Opus listers that are currently open. (You can keep the Preferences window open.)[/li]
[li]Double-click the folder on the desktop. Does it open in an Explorer window as it should?[/li]
[li](You can then change the settings back to how they were if you wish.)[/li][/ul]

I did this test as instructed and the results are as follows. Double clicking this new folder which was added to exclusion list simply does nothing, while at the same time double clicking other folders on Desktop open them in DO. So basically, hooking folder opening operation by DO does work, yet DO fails to launch Explorer (or maybe fails at passing folder path to Explorer) when working with folders it shouldn't open by itself.

Funny thing is that this happens not only when double clicking folders but also when using default "Open in Directory Opus" option from their context menu, while at the same time using "Open" option from folders context menu open them correctly in Explorer every time.

I belive there could be something wrong with the verbs in Folder branch inside registry. First thing that looks suspicious to me is the fact that there are three verbs in "HKCR\Folder\shell": "dopus_openinexplorer" (default as pointed by "HKCR\Folder\shell[default]" value) and "openindopus" + "open" (two keys which have exactly the same structure and values). Should it be like that?

It could be related to the registry settings.

If you can link your account and generate a log of the registry settings using my FileTypeDiag tool (leave the extension blank and just click "Save" to make it look at the directory and folder filetypes), I'll compare the output to my system and see if anything stands out.

It's also worth a try to reinstall Opus 10 over the top of itself (don't uninstall as that isn't needed and would wipe your config; just install again over the top) and then reboot. That would ensure all the components are properly installed/registered, in case the problem is there somewhere.