GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Copy & Move with TeraCopy

Yes, you are right. I uninstalled Teracopy and the items go away.
Thanks

This was the reason for joining to ask this question.
I am using latest version of tera copy 3.
I am using v.11 pro.
I would like to integrate tera copy with DO.
When I opened the text file integrated with teracopy it says[quote]Copy this code to the clipboard, go to the Directory Opus, and
paste "Copy" button to the toolbar in the Customize mode.

<?xml version="1.0" encoding="UTF-8"?>
<usercommand backcol="none" textcol="none">
<label>TeraCopy_CopyFile</label>
<tip>Copy files with TeraCopy</tip>
<icon1>%ProgramFiles%\TeraCopy\TeraCopy.exe,1</icon1>
<function type="normal">
<instruction>%ProgramFiles%\TeraCopy\TeraCopy.exe Copy *{allfilepath|filem} {destpath}</instruction>
</function>
</usercommand>

Repeat with this code to insert the "Move" button.

<?xml version="1.0" encoding="UTF-8"?>
<usercommand backcol="none" textcol="none">
<label>TeraCopy_MoveFile</label>
<tip>Move files with TeraCopy</tip>
<icon1>%ProgramFiles%\TeraCopy\TeraCopy.exe,2</icon1>
<function type="normal">
<instruction>%ProgramFiles%\TeraCopy\TeraCopy.exe Move *{allfilepath|filem} {destpath}</instruction>
</function>
</usercommand>

I've been googling for a while for what I should do exactly but failed to figure it out so here I am asking about clear instructions please if you may help me as this is really driving my nuts so far.
So how to add these codes to DO? where exactly?

The sticky post should have what you need: How to add buttons from this forum to your toolbars.

Does there is any YouTube video that make it clear?

Okay, so I've followed the instructions above, and pasted the text, and I get the following error message:

"Windows cannot find '<?xml'. Make sure you typed the name correctly, and then try again"

THis is what is in the text box

<?xml version="1.0" encoding="UTF-8"?>
<usercommand backcol="none" textcol="none">
<label>TeraCopy_CopyFile</label>
<tip>Copy files with TeraCopy</tip>
<icon1>%ProgramFiles%\TeraCopy\TeraCopy.exe,1</icon1>
<function type="normal">
<instruction>%ProgramFiles%\TeraCopy\TeraCopy.exe Copy *{allfilepath|filem} {destpath}</instruction>
</function>
</usercommand>

I didn't used to be this dim, but what am I doing wrong?

The sticky post should have what you need: How to add buttons from this forum to your toolbars.

(see the section labelled XML button definitions).

Hmmm. No, thats the section that I did. It doesn't say anything about the error message I'm getting.

You haven't followed it properly if you're seeing that error message. It sounds like you have pasted the XML into the command editor, which is not what the XML section says to do.

Really?

"Select Settings -> Customize Toolbars (the Customize window will open; keep it open but move it out of the way if it is obscuring the toolbar you want to edit)
Back in the lister, right-click your toolbar somewhere and (depending on where you clicked) there will be a New or Insert New menu. Click that menu, and then New Button.
Right-click the button that was just added and choose Edit.
For single-line commands, paste the command into the Function field.
For multi-line commands, click the Advanced button, then paste the command into the big area at the bottom."

Following these directions, I get a popup that says "XML buttons copied from the web should not be pasted into the button editor.

Instead, paste them directly onto your toolbars or menus.

To do so: Stay in CUstomize mode, right-click the desired location on your toolbar or menu, then choose paste"

And actually, with the XML code in the clipboard, this works (before, I didn't have the code already in the clipboard until after I was in the button editor). So for XML, all you need it the first step, and with your code in the clipboard, just paste it into a blank area of the toolbar.

Yes, really. :slight_smile:

As the first line of the FAQ says, "Buttons and toolbars can be shared in several different ways".

You are quoting from the Raw commands part of the FAQ, the very first section. That is for commands like the example it gives of Copy INSTALLFONT.

The section you want is the second section, which Jon referred to above, XML button definitions. That is for blocks of XML, as in the example for that section and similar to the code you're trying to use above in this thread.

1 Like

For what it's worth, I just did a file copy of the same files, first with DOpus, and then with TeraCopy.

DOpus was 28 secs, TeraCopy was 29 secs.

I'll still employ both for file copy / move operations, as TeraCopy has a few extras that make it very useful (verify file copy by hash). But DOpus seems to win for me when speed counts

I don't think the command is the same for using Teracopy with the Copy and Paste commands (Ctrl+c Ctrl+v). I have edited both functions to:

@nofilenamequoting
"%ProgramFiles%\TeraCopy\TeraCopy.exe" Copy "*{allfilepath|filem}" "{destpath}"

and

@nofilenamequoting
"%ProgramFiles%\TeraCopy\TeraCopy.exe" Paste "*{allfilepath|filem}" "{destpath}"

Here's the odd behavior: When I copy something, it automatically pastes to the other pane. If I paste or copy something that's not on the clipboard (empty), it just pulls up TeraCopy [it shouldnt do anything]. Thoughts?

I did added the two buttons but both are always active. How to set them as dimmed unless a file being clicked or selected?

Please link your account.

I am attempting to also disable the two added buttons when nothing is selected, but I am failing to do this. I modified the two scripts as follows:

@disablenosel
%ProgramFiles%\TeraCopy\TeraCopy.exe Copy *{allfilepath|filem} {destpath}
@disablenosel
%ProgramFiles%\TeraCopy\TeraCopy.exe Move *{allfilepath|filem} {destpath}

The buttons remain always enabled though. When I click the move button with no selection, it causes TeraCopy to crash.

Those look OK here and seem to disable correctly from a quick test.

Can you show us a screenshot of the full button editor / definition?

Here are screenshots of the button definitions:


Here is a screenshot with nothing selected with the two new buttons remaining enabled. Notice the existing toolbar buttons, such as Copy Files, are disabled:

@disablenosel needs to be on the toolbar button itself.

It looks like you are making user commands and then creating toolbar buttons which run the user commands. It's the toolbar buttons that need the modifier; having it on the user commands won't do anything.

Thank you. I deleted the toolbar buttons and recreated them properly. This is working fine now.

I was attempting to paste the XML documents into the toolbar many times, but there was no paste available. I now know that you must keep the settings window open in order for paste to appear.

Hi,
I've followed a lot of topics here in the forum and outside the forum.
I would like to know the right way to integrate tera copy with directory opus?
I tried to add the two button as mentioned in the tera copy preferences and it did added the two buttons for copy and paste using tera copy to the toolbar of the directory opus in the customization mode.
Then I found both buttons are always active even without selecting any thing (as mentioned by other members above).
Then I've removed the two added buttons from the toolbar using the same way, but this time I've just selected customize toolbar mode then right clicked the button and selected delete.
Now I would like to know the right way to integrate tera copy with directory opus.
Please advise :slight_smile:
And I would like to make buttons not active if nothing being selected.
Thanks :slight_smile:
Note: I've did tried the pinned thread but did not helped me.
Thanks my friend :slight_smile: