Crash running as RemoteApp

I run DOpus on my home server as a remote app under Windows 7 - super handy as I can use it as a pretty much limiteless remote application launcher, allowing nearly any app to be run semalessly remotely without the full win7 desktop in tow....

(there's a guide about this here: ... eally.html)

This has worked perfectly until the recent 10.4.0 upgrade - it now crashes every time: I understand this might not be a supported thing seeing as it involves hacking Win7 to allow remote app, but I suspect it might interfere with official remote app too....

I'm not really surprised that things crash after copying individual Windows DLLs from other versions of the OS. :slight_smile:

(If there is a problem with a proper Terminal Services machine then we'll fix it, of course.)

Yeah I get that, just saying it's been working with version from 9+ for about ?3 + years and it's just stopped. Bet you anything it will cause you other issues though :wink:

How do you know for sure the crash is related to the RemoteApp stuff and/or, out of interest?

Does the crash go away if you disable the RemoteApp stuff?

Have you tried installing to see if the crash goes away again?

When does the crash happen? During startup? When you're doing something?

It doesn't crash if I go back to or running directly on the Win7 machine. DOpus appears to start ok but as soon as you click on anything in the folder tree it crashes (or one thread does anyway but killig or not killing the thread both lead to crashes...)

What happens if you close the Folder Tree completely and then type C:\ into the location field? (i.e. Is the crash related to the tree, or just to changing folders?)

If the crash only happens when the tree is open, try turning off everything under Preferences / Folder Tree / Appearance / Show in Folder Tree and see if that makes a difference. (i.e. Maybe it's specific to one part of the tree.)

Well I've been trying it some more from another machine and it just crashes at startup so that's hard to try. It seems to either crash right on startup or on first click on the tree, can't close it. I do run Tortoise (SVN and GIT) and I notice you've done stuff there. Can I send you a crash log or something??

If you can get it to open without crashing... click on the tree toggle button on the Menu toolbar at the top right - or you may be able to just hit if you haven't disabled the Menu toolbar or modified it to use another hotkey. That will toggle the tree off so you can do the tests Leo asked about - and you might save that as the new lister layout (custom or default or whatever you're launching) so that the lister opens without the folder tree by default.

If you link your account and PM me the crash dumps (if any) then I'll take a look at them when I get a chance.

I've sent you a bunch of crash dumps Leo. Let me know if I can provide anything further.

I haven't been able to disable the tree as it keeps bailing out.

Got 'em, thanks!

From examining the crashdumps, it's a bug that we've already fixed in the newer beta versions.

Please grab Opus via the link in my signature and the problem should go away.

Yes the new beta seems to work again - great! I was just avoiding it because I use zip a lot and the new system is quite new....but I haven't hit any issues so far.

Thanks for your help!

FWIW, not much to do with zip or other archives changed in or

(If you're thinking of the Archives plugin update, that handles everything except zip files, and the current betas came out before the plugin update was finished. It will be part of the next beta,