Crash using filter bar with particular filename in lister

I have a crash when I try to do a filtering in a specific folder via * and then pressing the first char y.

It works fine in 12.21, which i now downgraded to.
do-bug do-bug2 do-bug3

If you go to Preferences / Viewer / Plugins and disable the JPEG 2000 plugin there, does the crash still happen?

Disabled JPEG 2000. Still crashing as before.

What do the crash dialogs say now? Do they still mention J2K codec or other components?

Have any crash logs been generated? Automatic crash logs (for bug reports)

I get nothing besides the runtime dialog currently, even with JPEG 2000 enabled. I only got that extra info once in a lot of crashes.

Also no dump dir/file.

If you scroll down the list of files instead of using the filter does the crash also happen then?

(It may be triggered by a particular file becoming visible, rather than the act of filtering.)

I can scroll down the list without problem. Only when i open FAYT and type the first char, then it crashes. And it's only in that 1 dir, not seen it crashing in any other i tried.

But the dir has a lot of files also different types, it's a dump dir for downloads and stuff like it for me.

Selecting anything from the drop downlist in the FAYT instead of typing a char also results in the crash.

The FAYT doesn't have a drop-down, so are you talking about the filter bar? Either way, it'll most probably be a file becoming visible and triggering metadata loading that's causing it.

Yeah the filterbar. The thing coming up after pressing * in a file list.

Did you scroll all the way down to the bottom? (Also, make sure you don't scroll so fast that anything gets skipped.)

It's likely that one of the files with a 'y' in the name is triggering the problem. If you can work out which file that is, it should point in the direction to look for the cause.

It's happening pressing any char in the folder.

Also scrolled through the entire file list beginning to end via Page Down and each time waited 1 second. No problem.

Got 1 more dialog this do-bug5

If you make a new folder and move everything from the downloads folder into it, does the problem still happen in the downloads folder?

If not, please try moving back a few files at a time until the problem starts happening again, to work out which file(s) seem to be involved.

Found it. It's a specific File with a weird character in it ... if i remove the character in the filename all is fine.

Made an empty text file with it that also results in this crash as soon as i open the filterbar and type anything.

I made a .7z here with this file... i tried it simply unpacking in empty folder and then using the filterbar results in crash.failure.7z (98 Bytes)


If you turn off both Ignore diacritics options under Preferences / File Displays / FAYT and Filter Bar Options, that should prevent the crashes for now.

We'll fix this in the next beta.