GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Crash when right-clicking RAR file

Whenever I right-click and attempt to extract a ",RAR" file I receive the error.

So it appears that whenever I try a "right-click" operation of any kind I am getting this error...

I have done a complete remove and reinstall of DOPUS, and still have these errors. Can anyone help?

Did you try any of the suggestions in the FAQ? Uninstall/reinstall wasn't one of them,

Actually I sent a dump email. Will they be able to diagnose?

I also just set the "Hide Windows items on the contect menu" and now right click works, but obviousy not much is available...

Strangely enough when I deselect the "Hide Windows items on the contect menu" my problem does not recur... Any idea why? Seems things are OK now but I didn't really do anything other than Hide, Unhide...

Spoke too soon. After runnning for awhile, it's back at it again...

BTW I am NOT having this issue with file explorer...

  • If the problem stops when you turn on "Hide Windows items..." that indicates it is coming from a shell extension that something has installed.

  • The crash dumps don't point to anything definite, but indicate a shell extension is probably corrupting memory when the right-click menu is used and shell extensions are asked if they want to add themselves to the menu.

  • What is the exact nature of the crash? There have been three different descriptions, and the details influence the best direction(s) to look in:

    1. Crash when right-clicking RAR file causes the crash? (As per the subject.)
    2. Crash when right-clicking RAR file and choosing an Extract option? (As per the first post.)
    3. Nothing happens (no crash, nor extraction) when right-clicking RAR file and choosing an Extract option, but if you then exit Opus it crashes? (As per email.)

    Or is it sometimes one of all three?

  • Is the Extract option you are clicking part of Opus, or is it another archiving tool?

    If you are not sure, go to Preferences / Zip & Other Archives / Archive and VFS Plugins and turn off RAR, then click OK. If the menu item is still there, it's not part of Opus.

  • Do you only get problems from the Extract option in the menu, or do you get the same problem (or a different problem?) when using any menu item after right-clicking a .RAR file?

  • Does the problem happen with other archive types, e.g. Zip files?

  • Have you tried using the debugging mode and ShellExView, mentioned in the FAQ, to see which shell extensions are involved when you right-click the file, and try disabling them individually? That is often the quickest way to isolate the cause of a problem.

    Also try disabling extensions related to cloud storage (e.g. Dropbox, OneDrive, Google Drive) even if they aren't mentioned by the debug mode, as they've been known to cause problems from time to time and it's worth ruling them out.

    Also try disabling antivirus in case it is involved, as it may be with archives.

I noticed the issue at first when trying to extract .RAR files by right clicking on the file and then selecting any of the extract types, "Etract Files, Extract Here", etc., using the WINRAR contect menu.
After that I noticed that ANY right click operation caused the issue. What happens is after right clicking and selecting something from the context menu, DOPUS just stops responding, when I end it, I get the error message.
At first when I selected the "Hide Windows items..." in preferences, the issue went away. When I deselected that option, everything seemed to work fine for a little while, but then I started having the same issue. I went through the troubleshooting steps, eventually turning off ALL of the non-windows contect menu items. Once again seemed to help, but then the issue started again, I had not adding them back in. I then unblocked all of them and once again selected "Hide Windows items...", but this time it had no effect. When I go to a text file and select "Open" or "Edit", it hangs.
I uninstalled winrar, but that had no effect.
I uninstalled any programs that contributed to the contect menu, that I had installed recently, but still no effect.
I have turned off Anti-Virus and malware programs to no avail.
The only thing that looks strange is the following lines which I see in the debug view window right around the same area as DOPUS:
[3028] onecore\base\appmodel\resourcepolicy\gameconfigstore\client\gameconfigstoreclient.cpp(104)\ResourcePolicyClient.dll!00007FFC90DBBA6C: (caller: 00007FFC81233FB6) LogHr(196) tid(1670) 80070490 Element not found.
[3028] onecore\base\appmodel\resourcepolicy\gameconfigstore\client\gameconfigstoreclient.cpp(104)\ResourcePolicyClient.dll!00007FFC90DBBA6C: (caller: 00007FFC81233FB6) LogHr(197) tid(1670) 80070490 Element not found.
[13324] SQLite error (5): database is locked
[7132] CNoteStoreClient::getSyncState: executed in 0.095577 sec
[7132] CNoteStoreClient::Connect: executed in 0.096255 sec
Not sure where to go with this. Right now DOPUS is BROKE for ALL right click operations.

Well... I just uninstalled the NEW Backup and Sync program from Google, replaces google drive. Things appear to be working now. I will monitor for awhile, but as soon as I uninstalled it, we are back to normal, at least for now. Any other issues reported with this?

It was definitely the Backup and Sync program from Google. Everything is performing well, since I uninstalled.

Well I must say I like the product, I've been a DOPUS user for quite a while. The TECH support is pretty BAD. I got NOTHING but a link to some suggestions about troubleshooting, and a snide comment. I had to identify the issue ALL ON MY OWN, and have heard NOTHING back since I identified it.
I would recommend that you include my identification of the issue in your troubleshooting steps.
Thanks again for NOTHING,
Greg

If an issue is caused by a bug in a third party shell extension on your machine, all we can do is tell you how to find it.

As it's not installed on our machines, only you can find it (unless you give us access to your PC).

As the bug is not in our code, we cannot fix it; we can only tell you how to avoid the problem by disabling the bad shell extension (either system-wide or just in Opus).

The problem is in Google's code in this case. Have you reported it to them, as per the FAQ I linked to? Google are the ones you should be directing complaints to in this case, although experience says they will not even reply or try to help, let alone provide a path to resolving the problem as we did.

Thanks for the defensive feedback. Actually the "path to resolving the problem" was a dead end. I tried EVERY suggestion you provided, to no avail. I finally started looking at software I had installed over the previous 2 weeks, and uninstalled them, one at a time. That was My "Path to resolving the problem".
So... Have you added my suggestion to your "Path to resolving the Problem" so other users who use Google Backup and Sync, which is everybody who used Google Drive, will have a clue if they have my same issue? I doubt you have, that would be customer service, which apparently is NOT your game...

What is it you think we should have done that we didn't do in this instance?

Well, I made 13 updates to the problem, as I was checking for solutions, You made 3, of which only 1 was constructive.
I also suggested that you provide the GOOGLE bug to other users of DOPUS in case they encountered the same issue. Was that done??

Shell extensions are other people's code in DLLs which are automatically loaded into other programs (such as Opus) when they do certain things, and then that code (e.g. written by Google in this case) runs inside those programs (e.g. dopus.exe). That code can do anything, including crashing the process or causing other problems. It's entirely outside out control, other than that we have the ability to block some DLLs being loaded in some situations. (We do that for a few which have had problems reported consistently for a long time without updates/fixes from the vendors, but it's rare for it to be needed.)

If the problem comes from Google's software on your machine then how could we have tracked it down for you? And what can we do about it now?

Have you spoken to Google yet, since it seems to be their component that was crashing? How helpful were they?

This forum is for support of Directory Opus. We aren't general tech support for your whole computer and all the software installed on it. Even if we had the spare time to support, say, Google's software for free as well as our own, we wouldn't really be able to as we don't have knowledge of, or the source code to, all the other software that might be on your PC.

Where a problem affects Opus, we do our best to help you track down the cause. Bugs are unpredictable by nature, especially ones caused by 3rd party code doing unknown things inside another process. We have added diagnostics to Opus such as the right-click menu debug mode and crash dumps, but in some cases they won't help and you have to go through the list of extensions in ShellExView disabling everything and then re-enabling things to see where the problem is. The diagnostics often provide shortcuts to avoid that, but sometimes there's no way around it.

The main right-click diagnostics also won't help if your machine has a problem which breaks DebugView, but that is not our fault. DebugView is a Microsoft tool that works for almost everyone, but if something installed on your PC is breaking it then it's not fair to blame us for that, and it points to potentially bigger problems somewhere, as it is not just Opus that's being affected. (Or there may be two small, unrelated problems, of course.)

If Opus is the cause of a crash then we will fix it or provide a workaround. If the cause is outside of Opus then we provide/suggest ways to block it from being loaded into Opus, but ultimately the vendor is the only one who can fix their code, and you need to talk to them.

And if you attack us over what appears to be someone else's bug and demand we do the impossible then we will be defensive, yes. That's only logical. We are not punching bags here.