GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Crashes after opening drive

I copied files from an external USB-drive to a FTP-drive
From then up DO crashes permanently, no drive can be opened
Unfortunately I could not find any DO - log file

I found this information in the Windows.Protocol

Name der fehlerhaften Anwendung: dopus.exe, Version: 12.21.0.0, Zeitstempel: 0x5ef01d76
Name des fehlerhaften Moduls: ntdll.dll, Version: 10.0.18362.815, Zeitstempel: 0xb29ecf52
Ausnahmecode: 0xc0000374
Fehleroffset: 0x00000000000f9229
ID des fehlerhaften Prozesses: 0x2bbc
Startzeit der fehlerhaften Anwendung: 0x01d66722dad45252
Pfad der fehlerhaften Anwendung: C:\Anwendungen\Tools\DOpus\dopus.exe
Pfad des fehlerhaften Moduls: C:\WINDOWS\SYSTEM32\ntdll.dll
Berichtskennung: 4d1edc42-351f-4f17-b0f7-4aa1f62deb9e

Is it still crashing even after a reboot?

What happens if you double-click a folder on the desktop to open that instead of re-opening the old paths? (Something in the folders may be triggering the crash.)

Which version of Opus are you seeing this with?

Sometimes people look in the wrong place, so just in case: Automatic crash logs (for bug reports)

Hi Leo,

  1. I rebooted and DO continues to crash
  2. I double-clicked a folder on the desktop and DO opens, when I click into that folder DO crashes
  3. DO is version 12.21.0.0 PRO

I found the minidump and attach it:
dopus.20200731.114814.zip (153.2 KB)

Cheers, Connie

So Opus can open OK for a folder on the desktop, but when you click on another folder is crashes? Have I understood correctly?

Which folder is causing the crash? What kind of drive/location is it?

If you copy the contents of that folder to a local drive, then go into that in Opus, does that also crash, or is it OK?

Thank you!

Based on that, could you try disabling the HiDrive shell extension to see if it is involved?:

  • Download the 64-bit ShellExView and run it
  • In ShellExView, scroll right until you can see the Filename column, and sort by that.
  • Scroll down to find any DLLs which are under
    C:\Program Files (x86)\STRATO\HiDrive\ShellExt\
  • Select those, then right-click and choose Disable Selected Items.
  • Reboot, and test if the problem still happens.

After doing the test, you can re-enable the DLLs in the same way.

Please let us know what you find.

If there are any other minidump files, please send them to us as well, as they may reveal more.

Good morning!

I will try to answer in sequence of your last message.

  1. I can define the situation more precisely:
    a) I can doubleclick on a folder on the desktop and it opens in Opus. When I click on a subfolder, Opus crashes
    b) Opus is set to open by autostart, it shows my folder layout (shows drive d: and g:), when I try to open any folder it crashes
    c) When I open Opus by clicking on it's icon, it opens the default layout and any click on a folder Opus crashes

The very first crash happened when I tried to copy to the FTP-drive, but now Opus crashes with all drives and folders, not only FTP-drives.

  1. there is no other minidump than the one which I sent to you with the last message

  2. I will disable the STRATO DLLs now and reboot. More details after that.

well, unfortunately the disabling of the STRATO DLLs and the reboot didn't change anything.

I recorded with a screenrecorder and uploaded the screenrecord (a webm-file) to a cloud, check here:

https://www.magentacloud.de/lnk/9giljBMl

Hello,

My DOpus has also just started crashing this morning! I was using it OK and then it crashed, now whenever I try to run it from whatever means it crashes. I've rebooted and it still crashes. I've reinstalled (over the original) and it still crashes.
I get two error windows (attached, if I've uploaded them correctly).

Please can you help
DaveDOpus 1 DOpus 2

Hi,

OK, so I completely uninstalled DOpus, restarted and reinstalled and it still crashes.

What happened overnight!!!! What is with the 1st August!!!

Dave

@daveinuk: Please send the crash logs to us:

That looks like a 3rd party DLL crash based on the info so far, but the crash logs should reveal more, and hopefully point to which DLL it is if that turns out to be correct.

Thank you for trying that, and for the helpful video!

Do you have any scripts installed? (Preferences / Toolbars / Scripts.) Those could be getting involved when you change folders, perhaps.

If the problem still happens with all scripts disabled, would it be possible to check if Opus still crashes when the default config is used? Here's how to test that:

  • First, backup your existing configuration so you can go back to it after testing. (Settings > Backup & Restore.)

  • Uninstall Opus via Windows. (Start > Settings > Apps in Windows 10.) This will wipe the config, so be sure to do the backup first!

  • Reboot to let the uninstaller delete any files that were still in use.

  • Install the latest version of Opus again, and then test if the problem is still there.

Once done testing, you can restore your config via Settings > Backup & Restore again.

Please let us know what you find.

If it looks like the config is involved, it might make sense to email that to us (crashdumps@gpsoft.com.au) so we can try with the same config. (Please don't post it to the forum, since it might contain private data.)

Config .ocb files are really .zip archives, so you can rename them and open them to see if there are any details you want to remove. The main one is the ConfigFiles/ftp.oxc file which might contain site passwords, if they're saved into your config; we don't need those so that file can be edited to remove them, or deleted if it's easier.

One other quick thing that's worth testing, in addition to my previous post:

Please try turning off this option and see if the crash still happens:

  • Preferences / Folders / Folder Display / Display localized folder names

The way that option works has changed slightly, and the folders in the video either use or contain localized names, so it could be involved. (I think it's unlikely, but it's possible, and can be tried quickly.)

If that does make a difference, the latest beta may already solve the problem, if you haven't tried that yet.

I changed the language to English so I can follow your suggestions more easily and I turned off this option "display localized folder names"

This doesn't help, so I will uninstall, reboot, and install the newest version but I must do my kitchen work now

I will password protect the screenvideo now, if you need it again, I can send you the password

Cheers, Connie

1 Like

it is workind now, but I will send you my configuration

these were the steps:

  1. I backed up the configuration

  2. I uninsttalled DOPUS

  3. I rebooted

  4. I cleaned the registry, all remaining references to DOPUS deleted

  5. installed DOPUS 12.20 and tested: it seemed to be ok

  6. I closed DOPUS, re- enabled STRATO DLLs and opened DOPUS again

  7. update message came, downloaded DOPUS 12.21 and updated

  8. re-installed my license and tested, result:
    I could open files on external USB-drives with assigned driveletter G:

  9. I restored my configuration: completely and tested after closing and reopening:
    10: it crashed!:
    in these situations:

  • opening an USB-drive with assigned driveletter G:
  • opening link to stored FTP-connection in toolbar
  1. when I re-enabled "Display localized folder names" again, it works
  • opening an USB-drive with assigned driveletter G:
  • opening link to stored FTP-connection in toolbar
  1. no new minidumps were created

so it seems to me that with the version PRO 12.21 x64 build 7.4.8 06.22.2020 is ok!
But I will send you the configuration

Cheers, Connie

Good that it's working! But also strange, since it doesn't sound like anything has really changed.

Thanks for your support. I will come back if this happens again, but maybe the fresh installation and the registry cleaning cleared the environment.

Cheers, Connie

1 Like

HI, just an update on my crashes.

Once Leo suggested that it must/could be a third party DLL, I went to Windows Explorer (now that is something from the past and it make me realize how much better DOpus is :grinning:) to start looking for things and it was behaving very strangely, crashing etc. I realized something wasn't right with my PC and it was going to take ages to find.
I restored to a backup and all now working, but not sure what caused it, but I do know it wasn't DOpus.

Great software (ever since the Amiga days) and 1st rate support.

Thanks
Dave

1 Like