Crashes, Crashes

Is anyone else experiencing frequent crashes with Dopus 8.0.1.2? I'm experiencing two distinct types of crash behaviour:

  1. Dopus just suddenly disappears when I'm clicking about in the GUI. The System Tray icon remains, but when I move the mouse over it, it disappears too.

  2. A Dopus dialog pops saying the dopus_lister thread has "encountered a program error" (0xC0000090 at 0x70F379) and offering to try and terminate it. Whichever option I select, it goes unresponsive and when I close it, the standard MS application crash dialog pops inviting me to report the problem to them.

I'm using an Athlon 64 machine with Windows XP Pro SP2.

Try disabling all plugins, particularly the movie one.

Does it tend to happen when (or shortly after) viewing certain directories, or directories with certain types of files?

It could also be a namespace, shell extension or some other kind of Explorer add-on that isn't working well with Opus, although I've not seen a crash result from such a thing.

I experience crashes similar to the second item as mentioned by JohnHind...and it is reproduceable every time.

Also when installing an update to DOpus...it automatically adds an icon to the desktop....despite there already being one there.

Have you tried disabling plugins? What about the other things I mentioned?

Some of the newer plugins seem to cause crashes for some people, and the older movie plugin can also cause crashes due to badly written codecs. Depending on what goes wrong you may not see instability or a crash until sometime after a plugin has been in use, so it's always worth a try to disable them all and see if you get stability back.

Also remember that almost every action you take in Opus can invoke plugins, since Opus calls most of them (depending on their flags) to see if they recognise files. (Opus doesn't just recognise files by filename extensions, plugins can look at the actual contents of them.)

All plug-ins have been unchecked...but it still crashes and is reproduceable every time.

I am right-clicking an .avi file to change the player (Open With...)...as WMP doesn't playback the file very well.

PS. It happens with .mpg video files also. :frowning:

I get this too.

I should add I deleted all files in the Viewers directory, restarted DOpus and got the crash. So it's not plugin related.

Here's the dialog that is displayed:

[quote]I am right-clicking an .avi file to change the player (Open With...)...as WMP doesn't playback the file very well.

PS. It happens with .mpg video files also. :frowning:[/quote]
Sounds like a conflict, when trying to build the right-click context menu, between Opus and the movie playback program(s) you've got installed. Which ones do you use?

Presumably you don't get the crashes anymore if you turn on Preferences, Miscellaneous, Windows Integration, Hide Windows items on file context menus? If so that would confirm it as a conflict between Opus and another program and hopefully it'll be easy to solve or work-around (depending on where the fault lies) once the actual program involved can be worked out.

In my case the only one that appears in Explorer is WMP.

Considering the problems that have been found in generating the right mouse menu maybe it would be best to wait till GPS release the fixes for these before trying to trace this down.

Also I would suggest they introduce a logging facility (e.g. at a bare minimum dumping the COM class ids) to aid in debugging these types of problems considering the only other method is having to uninstall applications which (IMHO) is unreasonable to ask a user.

Hi.

My problem with crashes has been going on some months. I installed and bought Opus (which I LOVE BTW!), but it just bugs-out about once a day with no input from me.

My PC is on 24/7 and is super-stable. By that, I mean I have not had a BSOD or major crash in months. As far as I can tell by using a cocktail of anti-spyware, and antivirus programs it is nasty and rootkit free.
However, if I leave any Opus windows open and go to bed, return 7 or 8 hours later, 90% of the time Opus has bombed in my absence. The icon will still be ghosted in the System Tray, but go to click on it and it will vanish. Nothing shows up in the event viewer either.
I get no bug reports or warning dialogs, Opus just vanishes.
I installed it with its default settings (Unicode version).
I have been getting these crashes at least since v8.1.0.8. Currently on v8.2.0.2.

Regards,
Susi

Crashes which happen when you're not using Opus can be really hard to track down. They may still be caused by 3rd party shell/context menu extensions on the machine (as discussed in a couple of the FAQs) but without a clear cause-and-effect way of reproducing the crash it's hard to pin the problem down to anything, without uninstalling software and playing wait-and-see. :frowning:

I leave Opus running all the time, sometimes for a week or two between reboots, and it doesn't normally exit so the problem should be solvable in theory, but working out what's going wrong probably won't be simple.

Thanks nudel, I'll try turning everything off and see what happens.
Regards...

Hi my Opus always crashes when I open my mp3 fold. In this fold I only have MP3 files. I tried all the things that nudel tips in the FAQ "Crash or exit when
viewing a certain directory", but none of them worked.
What should I do now??
Thanks.

Try and work out which mp3 file is causing it, and then make it available (via ftp if possible) for us to download to work out why.

I moved mp3 files around trying to figure out which one caused the crash but I could not, It seems to be random. I have about 40 songs in my fold.