Crashes on 64 bit XP machimes

I've tried a few things from your support forums but Dopus crashes often on multiple machines with the attached message. It can then take 15 minutes before we can load it again.

Help would be appreciated.


Your subject says "64 bit XP machines" but that screenshot looks like it's from Windows 7.

Yes indeed - Windows 7 I meant.

The crashes are ongoing and relentless. I've disabled all viewer options - no difference. It's happening on more than one machine.

We have been using Directory Opus for many years. I've had to revert to Windows Explorer.

Anything I can try?

These guides have suggestions that may help track down what's going wrong:

[ul][li]Crash, exit or high CPU usage when viewing certain directories[/li]
[li]Crash, exit or high CPU usage when right-clicking certain files[/li]
[li]Crash dumps for bug reports[/li]
[li]General slowdown or instability investigation steps[/li][/ul]

I'm trying to send you a dmp file but Upload Attachment does not work - clicking Add displays a page saying the page cannot be displayed.

I have tried a few things from the Crash list you sent me - no luck.

If it's easier, please zip up the dmp file and you can email it to:

I have sent you the file via your email address - thanks

Thanks for sending the dmp file.

From looking at it, it looks like something has corrupted the shared memory heap which is used by the Windows shell. (e.g. This can be caused by something allocating some memory and then freeing it twice by mistake.)

It's possible Opus itself is responsible, but more likely that a shell extension is doing it (as we've only have one other similar report recently, at least so far).

I recommend using ShellExView to disable all non-Microsoft shell extensions, then fully exit Opus using File > Exit Directory Opus & restart it, to see if the problem goes away. If it does, you can disable a few shell extensions at a time to see which one seems to make the problem return. The first guide in my four links above covers this in more detail.

Thanks for your help - I've disabled all non-Microsoft addins using ShellExView. including yours. That seems to have cured the problem.

Now it's a matter of switching them on again. Perhaps it's one of yours?

I doubt it's one of ours as they're more for use outside of Opus and we would also have a lot of problem reports if our own shell extensions were causing crashes inside the same program they are shipped with.

We are still crashing unfortunately but not as much. I have:

  • Using Shell View Ex have disabled all non-microsoft items, including yours
  • Using Shell View Ex have disabled Office microsoft items
  • Hidden Windows Items on File Context menus in your Windows Integration preferences
  • Switched of all View Plugins in D-Opus preferences

Once it crashes it takes a while to get it back, despite killing off Dopus items in Task Manager

You suggest we now use Microsoft debug - trouble is we cannot make it happen - it seems to be random.

This is a Win 7 64-bit machine.
Any advice please?

There must be a software component, or set of files being worked on, or activity, or similar which is common to all the machines seeing the crash.

Thinking about them may help narrow down what's causing the problem.

e.g. If the crash only happens after you go into a particular folder and look at lots of video files in thumbnails mode, then it might turn out to be caused by a bug in an installed video codec which is being used to generate the thumbnails.