CSV-Viewer (table form layout) (32-bit only)

Hi Dinkelhopper

Great idea and a very useful viewer!

Today I stumbled over a small problem. When the Header Row contains quotes the data is not loaded into the grid.

This is not loaded. It will be loaded if you check "No Header Row":


This data is loaded without problems:




That does not seem to be a big problem. I'll have a look on it tomorrow.

Okay, the bug is fixed.

New Release in Post #1.

I don't think there's a way to now - and it probably hasn't come up with a lack of MANY plugin's being developed, but looking at this I thought it might be nice to be able to do something like:

Set VIEWPANE Toggle,"plugin=CSVplugin"

...or some such business - basically to be able to do a one click viewerpane toggle AND select the plugin to be used.

You can do that with the standalone viewer window (Show PLUGIN=xyz) but not, AFAIK, with the viewer pane.

You know what to do. :slight_smile:


...BACK IN MY FACE - :laughing:

Hi Dinkelhopper

Thanks for the update, it works! :slight_smile:


Just wanted to add a thanks :wink:

Great Idea and a great Plugin.

Best Regards


Bugfixrelease (Post #1)

New Release post #1

Update: A workaround for this problem is included in Directory Opus which just came out.

Please see Heads-up: dopus_fileinfo crashes and solution if you're using this plugin and have found Opus crashes sometimes.

Hopefully it'll be easy to fix but I figure the mysterious crash may be causing problems for some people so it's worth giving everyone a heads-up on how to avoid it for now.

A workaround for the dopus_fileinfo crashes has been included in Opus If you use this plugin then you should update Opus to avoid the crashes.

This is a very useful plugin for viewing files with comma-separated values. Is it possible to configure the plugin to use a comma rather than a semicolon as the default separator?

Yes: Edit CSVViewer.ini in the same directory as the plugin DLL and change the separator line:


I feel very dim. CSVViewer is the first "forum" plugin I've tried to install (apart from Delphi Preview which "just worked" from its own installer).

I copied the dll and ini to the Viewers subfolder as directed in readme.txt, but I don't get nice preview in the Preview window if I click on a csv file.

I tried closing all DOpus windows and reopening, or even ending all Dopus tassks in task manager, then restarting. But nothing gets the proper preview working.

What have I missed? Or is it perhaps because it won't run in the x64 version of DOpus??



The plugin linked in the original post is 32-bit only unfortunately.

Right. It looks like it might be compiled in Delphi. If anyone has a way to put Dinkelhopper in touch with me (I can't find a contact means for him), I am happy to try compiling a 64 bit version in XE2. Find me under the People link at webcentre.co.nz.

Try the PM or Email links on the right of his posts, if you haven't already.

Thanks for pointing that out - I kept looking for a URL over his handle at left or right, but missed the PM button at right completely. Have used it.

Any news on contacting the author / an x64 version !?.. o)

Had to deal with massive csv-data these days and could not get the plugin to run, i found these last posts, now i know why.. o)