Ctrl+F (Find...) starts in wrong folder


In DOpus x64, if I start with "C:" selected in the Folder Tree window and type Ctrl+F, the Utility Panel for Find opens at the bottom of the screen as expected -- but the path listed there is "C:$Recycle.Bin".

Also if I first click on any given folder, then click on the root of C: again, and THEN press Ctrl+F, the default Find folder will show that given directory instead of C:. If I press Ctrl+F a second time, the starting folder shown in the Find Utility Panel changes to the correct directory.

Furthermore, sometimes when I select any given folder (which has subfolders of its own), and then press Ctrl+F to start a Find, the starting Find folder will show the first child folder of the currently-selected folder. It should start at the selected folder rather than (sometimes) that folder's first child folder.

Here is a screen shot where I only started up DOpus and then pressed Ctrl+F. As you can see, "C: (CDrive)" is highlighted in the Folder Tree window (that's from my default Lister), but the "Find in" location is showing "C:$Recycle.Bin". It should start the search at C:\ rather than C:$Recycle.Bin. (I added the highlighting.)

Is this a new feature, that by default the Find starts either one level deeper than what's currently selected in the Folder Tree window or in the last directory shown, rather than the one currently highlighted?

This just started happening recently, and the only config changes I've made are in the Toolbars shown at the top of the screen. I didn't see any config options about this behavior.

Thanks much!

Turn on the lock icon:

Thanks for the quick reply, but no dice. Here's another screen shot after clicking that lock icon, shutting down DOpus properly, rebooting the machine, starting DOpus from scratch, and pressing Ctrl+F:

I then closed the Utility window, navigated directly to C:\Archive, and then back to C:\ again, then pressed Ctrl+F:

I then closed the Utility window, navigated directly to C:\Program Files, and then pressed Ctrl+F:

As you can see, sometimes it seems to be trailing by one folder, and other times it seems to be selecting the first child under the current folder.

Also the "Lock" folder icon is indeed set. I noticed the keystroke to toggle that feature is Alt+L... there's a good chance I pressed that keystroke by accident at some point meaning to press Windows+L to lock my PC.

Can you try to duplicate these steps and see if you get the same results? I've used the Find feature this way for years, but it only started acting strange today. It used to start the search in whatever folder I've selected in the Folder Tree window.


What happens if you navigate to a folder while the Find Panel is still open?

Have you changed the command that the Ctrl-F (or Tools -> Find Files) runs?

If i navigate to another folder while the Find Panel is still open, the Find panel itself doesn't change. The Folder Tree window and main file lister updates accordingly, but I've found pressing Ctrl+F again updates the "Find In" folder.

I don't know how to modify what Ctrl+F does.

I tried to find something that would totally erase all my custom settings and reset everything back to defaults, but couldn't find such a thing. So I've just uninstalled DOpus entirely and will now reinstall. My plan is to see if this is out-of-box behavior or if it's related to something I might have customized in its Settings. I see there are still several entries for DOpus in the registry, but I'm not going to mess with them.

Thanks again!

Ok I've uninstalled DOpus, rebooted, reinstalled, (NOT applied my previously backed up settings, so everything is out-of-box), and now it seems to be working correctly! The starting "Find in" folder is the same as that selected in the Folder Tree, and I see the "Lock" icon is not locked.

I'll carefully step through applying all my previous customizations to see if I can discover the one that caused this behavior.

Thanks again.

After reinstalling, I see a few Toolbars are missing. Here's the fresh install:

And here's what it looked like before I wiped and reinstalled:

Evidently DOpus used to ship with different toolbars or something. I really like 'ListerMenu' and 'TabBar', but do you think those might be causing the problem?

You can get the Opus 9 toolbars here if you want to try them or use them:

Thanks Leo... I ended up uninstalling and reinstalling DOpus and the Find folder problem seems to have gone away. At one point I restored my previous configuration and the problem came back, so I restored again from a backup of a clean install and the problem is fixed again. I'll continue to restore other settings by hand and from memory.

This same problem is occurring on my home machine, too. FWIW I've been upgrading DOpus with each new release since about version 8. I've never created new config settings from scratch.

Thanks again.

FYI, I had this very same problem and managed to track it by backing up my existing configuration, uninstalling/reinstalling Directory Opus, backing up the newly stock configuration, unzipping the two backed up configurations to separate folders and using Araxis Merge to spot differences and mess around a bit. To make a long story short, here's the way to fix the problem: simply delete your /dopuslocaldata\State Data\find.osd file from your location configuration. The next time you open the find panel, it will default to the current folder and change appropriately. I don't know what circumstances mess it up, but once it's messed up this seems to be a reliable way to get it back to the way it was. Good luck to anyone who still cares!

Are you sure the lock icon wasn't just turned off? I think deleting that file has the side effect of turning it back on.