Default Lister is not showing in front of other windows

Hello team,

You are doing great as always!!!

I have a problem these days, I'm not sure if it happens with the final beta or the previous one.
I have set Double-click on the Desktop to - Open the Default Lister, the problem is that the new Lister is not always showing in front of all windows (some times it does),

Do I miss a setting, a change or is a beta bug?

Thank you in advance!

Does any body else have this problem?
I see no reaction after 2days!

Sorry to bother!


There's no change in how this works in the betas, or any similar recent reports. It's possible something changed on your system. Maybe another program is doing something which prevents the focus from changing, but I can only guess.

You could try going back to 12.9 to see if it still happens then if you do think it's due to the recent betas.

Thanks Leo,
It happens to any program I may have open.
Yesterday new windows opened behind Chrome, later Netbeans, today Arduino and Sublime text.
Does not happens always but is very annoying because I think I have miss clicked and click again and then checking the task bar I find several windows opened.
I'm in the middle of something but I will try your suggestion and I will report asap.


Sorry Leo it did not work!!!
Is doing the same also in version 12.9.

Any ideas???

I will try to capture some video tomorrow!

thank you for your time


Are you using any tools that change how windows behave, or how the mouse, or the Desktop works?

No need for video. The problem is understood. But I think the cause will be something external to Opus, unless you've made config/script changes at the time it began.

I've seen the same myself occasionally, too, but it doesn't keep happening. Sometimes Window fails to allow the new window to become active. But if it is happening a lot, I think something else must be involved.

Hi Leo,

I have not modified my setup in Opus for months except the theme options that you include and are always more than welcome.

Also in Windows I don't use any thing else weird!

To reproduce the problem set a Default Lister quite small size. Then start dbl-clicking Desktop around it. Even with no other programs open, you will see that the new windows are not always created in front.

Thank you!


Leo do you have any progress on this issue???

Today after restart II opened a Lister the I needed a new one and I started double clicking desktop. All new Listers were behind and I ended up with 6 Listers sucked behind the first one?

Is this an Opus problem or windows?
Is there a temporary solution?
Anything else that might help?

Thank you in advance!


We have no definite idea about what causes it, sorry.

I would try uninstalling any software that might change how Windows behaves, in case it is related.

From our point of view, we just ask Windows to let our window take focus, from the desktop thread which should already own the focus after you have double-clicked the desktop. Windows usually allows that to happen (unless it gets confused about window z-orders, which it does occasionally). If that isn't working, and is consistently not working, for you then it's not normal, and probably not something Opus is doing. Something else is preventing the focus change from happening.

There are other tools out there which respond to desktop double-click and might be doing their own thing (even if it's ultimately "do nothing" after checking their configurations) which could be taking the focus first. But I can only really guess.

Checking what your Preferences / Launching Opus / From the Desktop settings run, and disabling any script add-ins in Opus may also be worth a try, in case they're interfering in some way (but it's unlikely, unless they run something when listers open, or similar).

Hi Leo I found the problem.

After you mentioned the z-order I was trying to think what is wrong with that...

Finally I found that after a recent Windows Update the dock bar objectdock that I use for many years started misbehaving.

The strange thing is that I have notice it only with dopus!

Thank you!