GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Default Lister problem on multi-monitor set-up


#1

DOPus Support suggested I raise this on the forum to see if anyone else has experienced the same issue. This is a problem with Windows XP SP3 on a three monitor system and DOpus v10.0.1.0. (It happened with DOPus 10 betas and DOpus 10.0.0.0 too). DOpus Support are unable to reproduce the issue.

When I open a DOpus lister for the first time after Windows starts – by double-click on Windows desktop, if:

  1. I click on an area not on the monitor where the lister will open (I have a default position set in preferences) Dopus opens normally with twin horizontal windows set to my choice directory paths.
  2. I click instead in the monitor/area where the lister will open the two windows revert immediately to My Computer about 50% of the time. The back buttons on each window take me back to the original choice (there is only one back stored).

This happens only for the first time a lister opens (in that Windows session). It is not related to accidental double or treble clicking. It appears to happen only if the double-click to open a new lister is on the secondary monitor (i.e. it does not happen with a double-click on the main monitor). The default lister position is set to the secondary monitor.

Finally, it appears to be related to an application called Ultramon (www.ultramon.com) v3.1.0 that I run to manage multiple monitors. Ultramon is set to autostart but if I disable it before firing up a DOpus lister the problem described above does not happen.

Has anyone else experienced this or a similar problem (and have you found an alternative solution)? This is not a show-stopper by any means: it's a minor irritation but I (and DOpus Support) would like to get to the bottom of it.


#2

[ul][li]Does the same thing happen if you launch Opus in other ways? e.g. Put an Opus icon on the desktop and try double-clicking it, then fully exit Opus, move the icon to another monitor and try double-clicking it there.

[/li]
[li]If you set Preferences / Launching Opus / From the Desktop to Disable and then double-click the desktop, does anything happen? It's possible you have two programs both reacting to desktop double-clicks.[/li][/ul]


#3

Re: "Put an Opus icon on the desktop and try double-clicking it, then fully exit Opus, move the icon to another monitor and try double-clicking it there." – Yes, same problem if the short-cut to DOpus is on the secondary monitor.

Re: Disable launch from desktop – No, nothing else launches and there is no "busy" cursor icon indicating anything else running or trying to run.


#4

OK, after further testing I'll amend the first answer:

Re: "Put an Opus icon on the desktop and try double-clicking it, then fully exit Opus, move the icon to another monitor and try double-clicking it there." – Yes, same problem if the short-cut to DOpus is on the secondary monitor. After a cold boot following disabling the DOpus desktop start and starting a lister from a desktop icon instead the problem does not occur. I've tried this a fair number of times and the default lister launches normally the first time.


#5

Were you completely exiting Opus between each test before, or just closing all the Opus windows?


#6

The first time I disabled DOpus and turned off desktop launch before launching any lister, which I did from a desktop shortcut on the secondary monitor – the problem occured the first launch. However I did not cold boot the PC. I then cold-booted the PC and for that reboot and three successive warm boots the problem did not occur when launching by double-clicking the desktop shortcut.


#7

I'm not sure what that means. Did you exit Opus as per the FAQ I linked?

Also, you should make any config changes before exiting Opus, since opening the Preferences window will cause it to start running again.


#8

It means that I ended the dopus.exe process from task manager (which isn't what you had linked to, sorry I missed that link before). I then clicked on a DOpus shortcut icon that I had created by drag-and-drop copy from the Windows Start menu > All Programs. This was the first time that I opened a lister in that Windows session. Only then did I turn off the desktop start in preferences per your instructions (which is not what I said before – sorry again) and only then did I cold boot the PC. For that cold reboot and the three subsequent warm boots the DOpus icon was auto-launching in my Windows task bar but desktop launch was disabled. Each time I launched a lister by clicking on the desktop shortcut and every time the lister did not display the load "My Computer" behaviour. Neither did double-clicking on the Windows desktop show any activity/response.


#9

So it seems like you get the unwanted behaviour only if these are all true:

[ul][li]Ultramon is running.[/li]
[li]Opus was started running via desktop-double-click. (i.e. The first time you open an Opus window after rebooting, it is via desktop-double-click. Opus will then stay running in the background unless explicitly exited or configured not to.)[/li]
[li]When Opus is asked to open its windows, the mouse pointer is on a particular monitor.[/li][/ul]

Here's the next thing to try:

[ul][li]Go to Preferences in Opus and make sure Double-click on the Desktop is set to Disable. If needed, set it to Disabled and click Apply.[/li]
[li]Open Task Manager and go to the Processes tab.[/li]
[li]You should see dopus.exe but not dopusrt.exe.[/li]
[li]Exit Opus, as per the FAQ.[/li]
[li]You should not see dopus.exe or dopusrt.exe anymore.[/li]
[li]Start Opus again, and this time set Double-click on the Desktop to Open the Default Lister, and click Apply.[/li]
[li]You should see both dopus.exe and dopusrt.exe.[/li]
[li]Exit Opus again, as per the FAQ.[/li]
[li]You should see only dopusrt.exe in Task Manager.[/li]
[li]Double-click on the desktop, trying the three different monitors. What happens?[/li][/ul]


#10

Followed every step to the letter and found the appearance or not of dopus.exe and dopusrt.exe in Task Manager to be as you indicated. At the final step – double-clicking on the desktop – the default lister opened in my default location with my default paths set every time (i.e. the reported problem did not occur). It did not matter which monitor was clicked, it opened as advertised without the reversion to "My Computer".


#11

So, with it all working like that, does it stop working again if you reboot?


#12

Hmmm, I've only rebooted the once and I did not get the problem when I opened the lister. I'm in the middle of something right now but I will try a couple of warm boots to see what happens as soon as I can.


#13

Well I am impressed :slight_smile:. I've cold-booted twice and warm booted three times since you asked me if it stopped working again if I rebooted, and the double-click default lister has opened each time as advertised: i.e. no repeat of the "My Computer" problem. (I double clicked on the secondary monitor each time). Touch wood it is fixed.

Is there a technical explanation why it probably worked or was it just intuitive techie magic?


#14

I'm not sure why doing that fixed things, to be honest. :slight_smile: Glad it's working now though.


#15

Oh dear, I spoke too soon. Just logged on tonight and fired up my first Lister (after about 50 minutes) and the same problem…


#16

If you re-do the steps from my post (below "Here's the next thing to try"), does it start working again?

My hunch is that if the dopusrt.exe process, which handles desktop double-clicks, is started before UltraMon during system boot then UltraMon's patching causes something to go wrong. It's a pure hunch, and doesn't fully explain what is happening (the My Computer folders in particular), but if something like that is the trigger then exiting both dopus.exe and dopusrt.exe, then restarting both of them, will ensure both parts of Opus are started after Ultramon.


#17

It might be worth while switching from UltraMon to Display Fusion. I had a lot of issues with UM and DO and none at all since switching to DF.


#18

Thanks for the suggestion, Display Fusion looks interesting, it's cheaper than Ultramon and the license includes free lifetime upgrades. However, I've already paid for UltraMon and this issue is only a minor irritation (and if I double-click on the main monitor it avoids it altogether. It's not enough to make me switch. I haven't noticed any other issues with Ultramon and DOpus (or other software). If I do I'll certainly consider a switch to Display Fusion

Re Leo's timing point. I suspect you're correct and I have other software where I can delay start-up times for Windows Start applications. The truth is, I can't be bothered for such a minor issue :slight_smile:.


#19

Not a problem. I was a UM user myself for many years and then switched after the initial support for Windows 7 was somewhat lacking originally. With DF new beta releases come out fast and furiously to fix any reported issues so I'd keep it on your consideration list :slight_smile:

Plus it has a lot of features that UM does not have.

And no I'm not affiliated with the developers at all. :slight_smile:


#20

Just to flag that this problem is resolved (but not understood/fixed).

I had a catastrophic computer crash at the beginning of January – blue screen of death before even starting Windows for Windows system files that were corrupted, repair console failed to fix, etc. – that happened after a system diskcheck on the boot disk. As a consquence I had to reformat the system disk and resinstall Windows and all my applications again from scratch.

I'm still installing some applications but the majority of my most-used applications have been installed and I'm back to the same set-up as before. The problem with the default lister has vanished!!! Still running Ultramon and the latest version of DOpus (same versions as before), still three monitors, DOpus default lister opening on screen three. All the start-up applications and security software are the same as before.

So rather an extreme solution (that was certainly not planned) but still no idea what the underlying problem-cause might have been. It seemed fairly certain that it was an unintended interaction with Ultramon but whatever it was is not showing up following a full, fresh installation of Windows.