Defining a button to show only labels for certain folders

This is the code I wrote for the labelbutton:

Properties SETLABEL=!menu LABELCATEGORY=studio

Properties SETLABEL=!menu LABELCATEGORY=muziek

When I open lib://Studio, the LABELCATEGORY=studio is shown in the label menu. That's ok.
However when I go to lib://Muziek the LABELCATEGORY=muziek the corresponding labels are not shown but just the LABELCATEGORY=studio remains listed whatever I do. Should I reset something? There must be something wrong in my coding. I'm definitely not an expert in that. :face_with_raised_eyebrow:

I don't think it's possible using @ifpath, but you could do something similar by creating a separate toolbar for each set of labels, putting one command on one toolbar and the other on the other, and then turning the appropriate toolbars on for the folders you want it in.

Turning toolbar(s) on for particular folders can be done via Preferences / Folders / Folder Formats. Create either a path format (matches one folder, and optionally sub-folders) or a wildcard path format (can match multiple folders, using the wildcards you're using already) and edit it. On the Options tab there's a toolbar drop-down.

The toolbars themselves can be created via Settings > Customize Toolbars.

Thanks Leo. This is a good one! Did not consider this solution...

1 Like

It partially works! However I made a library shortcut on my desktop. When I double click on it , the assigned toolbar for the folder is not displayed. I first have to press F5 to display the corresponding toolbar. When I open a default lister first and then press the shortcut on my desktop it works like it should and the toolbar is being displayed. Strange?

Is that a normal Windows shortcut pointing to a particular library, or does it open an Opus folder tab group or something like that?

Made in Windows indeed..

Does this mean that I can't make "windows" shortcuts to get this properly working?

It works fine here, testing with Opus 12.21.2 beta.

I made it so the Drives toolbar is turned on when I go into the Directory Opus folder:

As you can see, that happens whether I enter it in an existing lister, or by opening a new lister via a shortcut on the desktop:

I must be doing something wrong because I can't get it done.
I'll try it again some time...

It keeps me busy to get it done because it's rather important for me.
Please see the attachement about my experience...

Is Preferences / Launching Opus / Default Lister / Ignore toolbars of Default Lister turned on or off? Try turning it on.

1 Like

In the Preferences/ Default Lister as you stated I turned the 'Ignore toolbars" of the default Lister to ON (it was off) and now the corresponding toolbar is properly displayed when I open the folder from the desktop. This problem was a tricky one... at least for me! :rofl: Nice, nice, very nice (Ambrosia)!!

Thank you Leo for helpiing me out...

1 Like