Deleting files sometimes crashes DO

Sometimes when deleting files DO will crash with the following information:

AppName: dopus.exe
ModName: tiptsf.dll
Modver 1.7.2600.2663

Machine is a Tablet PC, fully patched with all hotfixes. All other DO functions work, and no other program is crashing.

Any suggestion?

This seems to describe your problem:

Yes, I saw that when I searched the forums. The hotfix refers to Tiptsf.dll with version number of 1.0.2201.3 dated 19-Sept-2003; the version on my system is 1.7.2600.2663 and it's dated 5-May-2006.

Any other ideas?

There was a similar thread from jurgenhaas a little while back. It sounded like he was going to ask Microsoft for the hotfix (shame they don't make it more easily available!) but he didn't report back after that. Might be worth emailing him to ask how he got on.

Just saw your reply... Does seem odd that MS haven't fixed the bug in later versions of the DLL. Might still be worth asking jurgen if he tried the fix in case the fix wasn't integrated into release versions, I guess.

Might be worth turning off all extra columns which inspect file contents (e.g. Details) and Shell Image Extraction (or just avoid generating any thumbnails) to see if the crash is tied to either of those. If so it might be a shell extension that is loading the DLL and doing something wrong. But if that's not it then it does seem like a bug in the DLL (i.e. Microsoft's problem to fix) since Opus itself doesn't use the DLL directly.

Also worth avoiding plugins which could trigger external programs to be loaded, like the ActiveX plugin, as those programs may load the DLL.

Could be hard to track down what, if anything, is (ab)using the DLL, though, and judging by the KB article it does sound like a problem Microsoft at least tried to fix themselves.