Desktop double-click after update

Mine also started working after disable/enable. If if figure out which app is causing the problem I'll post back here. Thank you.

Perhaps I've been a bit slow in making this connection. My C: boot drive is not encrypted but my data drives are. After Windows starts I have a way of running a PowerShell script. This script prompts for a password, then uses it to unlock my BitLocker-encrypted drives, starts a few services and programs that depend on the data drives, then restarts Explorer (as there are a few Start Menu/Taskbar shortcuts/toolbars to previously inaccessible items that need to be refreshed to display correctly). The double-click works before restarting Explorer the first time (but I never use it as the default Lister tries to access locked resources).

To restart Explorer I run "Stop-Process -ProcessName explorer" which triggers an automatic restart. If I get the double-click working and then restart Explorer this way then it stops working again. I didn't think that this was the cause as I have been using this process for more than three years and it hasn't been a problem before. If restarting Explorer in this way causes the problem for you too, perhaps you might know what recent changes have affected it.

DOpusRT.exe should handle when Explorer is restarted, but I'll look into whether that still works on current versions of Windows when I get a moment.

You could work around that by making your script tell the old DOpusRT.exe to exist and then launch a new one after restarting after Explorer:

"C:\Program Files\GPSoftware\Directory Opus\DOpusRT.exe" /dblclk=off
"C:\Program Files\GPSoftware\Directory Opus\DOpusRT.exe" /dblclk

I was unable to get this to work properly in my script. It seems that if it is run too soon after Explorer has restarted (even from a separate script that I could browse to and run manually) it has no effect. So I wait at least a few minutes and then run it and then my desktop doubleclick if fine for the rest of the session.

Still my daily annoyance, not yet fixed in 12.27. After starting DOpus after Explorer has restarted, it seems I need to wait a handful of seconds before running .../dbclick will work.

After updating to 12.27 with the dbl-click not working at the time, the install's restart of DOpus made the dbl-click work again. It stopped again after running:

powershell -command "gps explorer | spps"

Hope you get around to this sometime. TIA.

It’s on our list to investigate why it’s happening.

But needing to restart Explorer for something else so much that its a daily annoyance suggests something else needs fixing, as that’s not normal (unless you’re developing shell extensions or something similar).

Well, as I mentioned, my drives (except C:) are BitLocker encrypted, and after startup every morning I run a PowerShell script to take a password and unlock all drives and restart Explorer so that shortcuts and toolbars to previously inaccessible drives get refreshed. Then at some point I double-click the desktop and it doesn't open a Lister, so I start one from a shortcut, navigate to where I have a shortcut to "DOpusRT.exe /dblclk=off; .../dblclk", wait a minute as it won't work if I run it too soon after starting DOpus for the first time, then run it and then I'm set until next reboot. Just an inconvenient little ritual that I'd rather do without.

I’d joke about asking Microsoft to fix Explorer so you don’t have to go through that ritual, but obviously they’ll never reply to a support request let alone fix anything, and we have to fix all the problems they create despite having a billionth of their resources. :slight_smile:

The next Opus update will have a fix for Desktop Double-Click not working after the explorer.exe is restarted. We found a case where the restart notification was being missed.

1 Like

I installed 12.27.1 (beta) and immediately restarted my machine to test. I'm very pleased to report that the issue is resolved for me. Thank you very much for attending to this. I'm going to have a little gap in my routine tomorrow that I will have to find a way to fill.


The latest update, 12.32, has broken desktop double-click launch for me again in Win10. Unlike the last time (described at the beginning of this thread) desktop folders will open but Dopus will not. I have not signed out or rebooted yet but I did restart Explorer and that is not the fix.

Anyone else seeing this?

It works OK here FWIW, and we haven't had any similar reports in a long time, at least as far as I can remember.

I've changed the way I do things, so wouldn't have noticed if there was a regression with the problem I previously had. But for old times sake I gratuitously restarted Explorer and had no issue dbl-clicking the desktop after to open a new Lister (12.32 Win10 x64).

I had to sign out in order to get it to work here. I have not yet installed the update on my Win11 machine. Maybe later today.