Desktop & explorer rendering

I tried all replacement options but... dopus keeps on using explorer to render my desktop folder if I come from "Computer" to it by going folder up.
Any way to force the desktop to be dopus rendered?

Under Preferences - Folders - Virtual Folders, add Desktop to the list of virtual folders to "treat as real".