GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Devices with Removable Storage are not sometimes displayed


#1

Hi guys, I have noticed this for a while:
lh5.googleusercontent.com/--TtE ... mputer.png and found myself having to option explorer.exe to access the device.

Left is Windows Explorer. Right is Directory Opus.


Hideempty and show empty drives works bad
#2

It may be due to the device not reliably sending notifications when it changes between empty and non-empty. Explorer is more forgiving than Opus with such devices. (Something we may add a workaround for in the future.)

I expect that if you fully exit Opus and then restart it, the drive will be listed.

If it's a common problem, you can turn on Preferences / Folders / Virtual Folders: Show empty disk drives, and Preferences / Folder Tree / Appearance: Empty disk drives to make Opus show the drive regardless of its state.

Of course, if those things don't make a difference then my guess about the cause may be incorrect.


#3

leo

Thank for the following settings:
If it's a common problem, you can turn on Preferences / Folders / Virtual Folders: Show empty disk drives, and Preferences / Folder Tree / Appearance: Empty disk drives to make Opus show the drive regardless of its state.

Above settings makes DO forgiving as Explorer :slight_smile:


#4

Any news on a workaround? This problem is very inconvenient. I have two thumb drives and a card reader connected to my computer right now, and they don't show up in the tree or on my drives toolbar when I have them set to hide empty drives. I don't like showing empty drives because things become very cluttered with virtual drives, empty slots in my card reader, etc. Explorer shows everything as I expect, hiding truly empty drives and and only showing devices that are not empty.

Just a note - if I remove one of the thumb drives and plug it back in, then suddenly everything works right and all my non-empty drives show up. But on startup, Opus gets confused...