GP SoftwareTwitter
Opus FAQsManualCommandsObjects

"Devices with Removable Storage" does not Refresh


#1

"Devices with Removable Storage" does not Refresh

Win.7 x64 -- dOpus 11.15 64 bit

I do have Paragon HFS+ for Windows 10.2 installed
to let me read contents between external hdds which I also use for Mac

but ... Windows Explorer does not seem to have this "problem".

#1) just now I properly clicked in the system tray to remove an exFAT USB Flash Drive,
and after removal, dOPus still shows it in the Lister -- even afer Refreshing the window,
even after Closing/Re-Opening dOpus, the removed drive is still listed.

Checking in Windows Explorer, it is NOT shown after removal -
Windows Explorer has removed it.

#2) same procedure w/ an external, multi-partition HFS+ / eXFAT USB hdd --
dOpus continues to show it in the Tree as well as in the main window of the Lister.

Again, Windows Explorer has properly removed it.

I've tried Disk Mgmt. Console > Refresh the view, but doesn't solve the problem --
the only procedure I've been successful w/ is to reboot.

Any ideas or solutions? THx ~


#2

When you restarted Opus, did youfully exit Opus (via File / Exit Directory Opus), or just close the window and open a new one?

If the drive is still showing up after a full restart then Windows must be reporting it to Opus in some way, but if it's only after closing & re-opening the window then it could be some incorrectly cached data.

Please also try turning off Preferences / Folders / Virtual Folders / Native display of 'Computer' and then going to My Computer in the file display (it won't affect the folder tree, so ignore what that shows for this test). Does the drive still show up then?


#3

apologies for the delay in being able to test your suggestions --

I tried all these, but none worked - problem still persists --
I must log out in order for the Lister to properly Refresh,
yet Windows Explorer refreshes right away.

I'll be happy to try more suggestions, Thanks


#4

If you're seeing the problem with Native View... turned off, and after complete shutdown & restart of the process, then it suggests that Windows is reporting the drives exist, at least within the dopus.exe process. Explorer itself would be handling the folder view, just in dopus.exe instead of explorer.exe, and it is showing the same as Opus was when it handled the My Computer folder itself.

So either something is different about the two processes (e.g. Opus has been run elevated via UAC, or as another user via Run As or similar; or antivirus is doing something strange to one process and not the other), or something strange or inconsistent is happening at the OS level.

Opus can only display what the OS tells it reality looks like, and it seems like Explorer agrees with Opus (when run inside the same process), so the problem must be outside somewhere.


#5

Finally had a hunch to try something different --

  • R-click on the Removable Drive in the main dOpus "Computer" window,
  • click Eject in the context menu
  • watch as the "Safe to Remove Hardware" notification pops up from system tray
  • watch as the Removable Drive disappears from the main dOpus "Computer" window :slight_smile:
  • physically remove the drive

... instead of 1st clicking on the "Safely Remove Hardware and Eject Media" sys-tray icon,
which seemed to cause the Removable Drive to remain listed in the main dOpus "Computer" window

:thumbsup:


#6

You're not running dopus.exe as admin (UAC elevated), are you?


#7

woah - forgot to change back to lower privileges after the last round of configs


#8

It's best to use Opus's admin mode instead of running dopus.exe elevated, or lots of things like that will break.