GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Directory Opus hangs ocasionaly on right-click properties

This is driving me nuts. Directory Opus (latest version 9.5.3.0.3728, 64bit on Win 7 pro 64bit but this was also on Vista 32bit if memory serves me well but not on XP) hang (I need to manualy close DO window by clicking on Close button) if I right click on hard drive icon. But I have found workaround, first I need to right click on CD/DVD drive icon, than I can right click on HDD drive icon to choose properties etc. Is there any solution to this bug/problem?
I run DO as stanard user.

[code]Description:
A problem caused this program to stop interacting with Windows.

Problem signature:
Problem Event Name: AppHangB1
Application Name: dopus.exe
Application Version: 4.0.2.21
Application Timestamp: 4ba014db
Hang Signature: 2ec8
Hang Type: 0
OS Version: 6.1.7600.2.0.0.256.48
Locale ID: 1050
Additional Hang Signature 1: 2ec882a3ff353c034cd8ecceafcadbe0
Additional Hang Signature 2: c84c
Additional Hang Signature 3: c84ce1af6cf73b8dd245b54c360f63f8
Additional Hang Signature 4: 2ec8
Additional Hang Signature 5: 2ec882a3ff353c034cd8ecceafcadbe0
Additional Hang Signature 6: c84c
Additional Hang Signature 7: c84ce1af6cf73b8dd245b54c360f63f8[/code]

See the FAQs. There's one about exactly this issue (diagnosing crashes when right-clicking files, which are usually caused by faulty shell extensions installed by other software).

If you think about this topic: Crash, exit or high CPU when viewing certain directories, been there, done that. I still think this is some Vista/Win7 issue, because I don't have problems in XP with Directory Opus. This is happening if I run DO from scratch (let's say if I completely close Directory Opus processes) and than directly right click on hdd drive icons. But after I do mentioned workaround (first right click on cd or removable drives icon), then I don't have problems accessing to hdd drives with right click. Maybe I will find what is causing this behaviour.

Also other workaround is to right click on some folder, then I can right click on hdd drive icon without fear of Directory Opus not responding.

Leo is referring to this FAQ...

Yes, I read also this FAQ. But I don't know which program would be causing this behaviour. I tried debug view utility, but it's only capturing events from right click on folder, not if I right click on hdd device icon, than it's blank. But I don't see reason, why right click work on folder or CD device drives, on first start, but not on hdd device.

The My Computer view is provided by Explorer so the Opus context menu debug stuff doesn't work in there.

Download the ShellExView tool linked in the FAQ and sort the list it displays by the Type column. Look at all the ones with Type = Context Menu which aren't from Microsoft (they'll be highlighted in red). Try disabling them all using ShellExView, then re-enabling them one-by-one until the problem comes back.

Of course, if you have anything in the list that's obviously related to disks, try that first. (e.g. The O&O Defrag context menu caused crashes like this at one point in time.) But if the disk-related items are fine then you should still try the others as they will all potentially be queried when a disk is right-clicked.

Thanks leo, with your advice I found problem. It is AlcoholShellEx64 Module which is causing all the trouble. ShellExView is showing two of them. Is this AlcoholShellEx64 Module necessary or I can use Alcohol 120% without it?

==================================================
Extension Name    : AlcoholShellEx64 Class
Disabled          : Yes
Type              : Icon Handler
Description       : AxShlEx64 Module
Version           : 2.0.0.1110
Product Name      : AxShlEx64 Module
Company           : Alcohol Soft Development Team
My Computer       : No
Desktop           : No
Control Panel     : No
My Network Places : No
Entire Network    : No
Remote Computer   : No
Filename          : C:\Program Files (x86)\Alcohol Soft\Alcohol 120\AxShlEx64.dll
CLSID             : {AF67B665-D752-424E-9A03-C7C218F2844F}
File Created Time : 5.2.2010. 2:58:20
CLSID Modified Time: 15.3.2010. 1:17:36
Microsoft         : No
File Extensions   : .mds, AlcoholImageFile
File Attributes   : A
File Size         : 624.480
==================================================

That would probably be a question for Alcohol support?

Of course. :slight_smile:
But I was just asking if someone here knows by the way, maybe someone who also use Alcohol 120%.

I was trying same thing for testing purpose on Win XP Pro 32bit, there I don't have this kind of problem with Alcohol 120% and Directory Opus.