GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Directory Opus slow with Dropbox folders


#5

Does it only happen when using, or not using, the Recycle Bin?

No this slow down happens whenever I change a file that is in one of my Dropbox folders. Change could be deleting or saving or renaming.


#6

If you delete a file using Explorer, while Opus is also showing the same folder, does the same delay happen in Opus in response to the action in Explorer? Or is the delay only when the action is performed in Opus?


#7

Yes, if I delete a file using the Windows Explorer, the delay is happening within Opus but not in the Windows Explorer even with both windows open (Opus and Explorer).


#8

I created a short video of the issue. I would like to send it to you privately so that you can see first hand the specific slowdown of Opus when deleting, renaming or saving files within a Dropbox folder.


#9

Sure, please email it to leo@gpsoft.com.au


#10

If you use ShellExView to disable the DropBox shell extensions, then fully exit Opus (via File / Exit Directory Opus) & re-launch it, do you still get the delays then?


#11

I disabled the DropboxExt for the context menu which also disabled another icon overlay handler. I then restarted Opus.

After disabling the DropboxExt context menu, I do not see that slow down within Opus.


#12

That seems to confirm the issue is within, or at least triggered by, the Dropbox shell extension.

If you want to find out if it's the context menu or the icon overlay, you can re-enable both via ShellExView, then add to context menu extension's CLSID into Opus's context menu block list.

To get the CLSID, right-click the context menu extension in ShellExView and choose Properties. The CLSID is near the middle of the window that appears. You can then add it here in Opus (more details here):

After doing that and restarting Opus, if the problem comes back then the issue is probably with DropBox's icon overlay handler. If the problem remains gone, it could be with the DropBox context menu.


#13

I have tried to do as you suggested but it did not work.

I added the icon and the context menu to the ignore list but it does not solve the problem. I still have the delay only within Opus. Windows Explorer does not have this issue.


#14

That indicates it is probably the DropBox icon overlay that is causing the problem. Leaving it disabled (via ShellExView) is probably your best option.


#15

I have switched back to this version of Opus:
Directory Opus Pro 10.5.7.0 (5215) x64
OS 6.1 (B:7601 P:2 T:1) SP 1.0 "Service Pack 1"

I do not have this problem with Dropbox within that version.

The solution that you provided me disables something within Dropbox that I need.

Do you know what is different within Directory Opus 11 when compared to 10 in regards to this particular issue that I am seeing with Dropbox.


#16

There are thousands of changes between the versions, so one of the differences may be triggering a problem with the Dropbox extension. We're not aware of any particular change that should make a difference, however.

Opus does not talk to DropBox directly, it just calls a Windows API which requests the icon for a file, and Windows in turn talks to DropBox (and any other icon shell extensions).


#17

I have this same problem...it's been bothering me for quite a while but I finally came here to search for the cause.

I'm also reluctant to remove the dropboxext that I do find useful.

I just wanted to mention that this is a problem for me too...so I hope GPSoftware does something about it and works around the issue internally! This problem doesn't happen in Explore (Windows 8.1) or XYPlorer (and alternative to DO I sometimes use).


#18

It happens for me as well. Doesn't bother me too much, but if it can be fixed without removing or disabling the dropbox extension, I'm looking forward to it.

Thanks


#19

It's worth reporting this to Dropbox, since the delay seems to be within their shell extension, when Windows asks it for an icon. It's unlikely we'd be able to tell why the delay is happening (even if Opus is somehow triggering the situation) as Opus does not call their code directly (Windows does), and we do not have their source code to see what it's doing.


#20

Just made a post in the Dropbox forums:

dropboxforum.com/hc/communi ... ox-folders


#21

I also just posted the following over in the Dropbox forum (in the thread mentioned above):

[quote]I am having the same problem. It has meant that I can no longer use either of my file managers when Dropbox is syncing or after any changes were made to files inside my Dropbox folder. But I keep ALL my files in Dropbox! If I make ANY changes (copy files, delete files, rename files), my file managers freeze and show "Not Responding". I can't work like this.

The only way to solve the problem is to completely disable all Dropbox's icon overlays, which is obviously not a solution.

See:

XYplorer + Dropbox problem:
xyplorer.com/xyfc/viewtopic.php?f=2&t=5573

DirectoryOpus + Dropbox problem:

I really hope that someone fixes this soon, either at Dropbox or at XYplorer/DirectoryOpus[/quote]

Note that I am getting the same problem in both DirectoryOpus and XYplorer.

PS: where can I get my hands on a copy of DirectoryOpus that :frowning: does work, to use until someone fixes this? I have a licence for 11, but would gladly go back to 10 if I could use Dropbox again. I am a very heavy Dropbox user (1TB Dropbox folder and a fibre internet connection) and need to see those overlays.


#22

I switched to XYplorer because of this issue. For some reason, I don't see this issue within XYplorer.


#23

Hi aaron,

That's interesting. Yes, it seems not everyone has the problem in XYplorer (I've asked around in the XYplorer forums). What version of XYplorer are you using? And are you on Win7? Win8? Win XP? Also: 32-bit or 64-bit?

This is driving me crazy. I have a lifetime licence for XYplorer, and a licence for DirectoryOpus 11, and yet am constantly on the lookout for yet another file manager, which I can actually use with Dropbox.


#24

PS: Have you had to switch off icon overlays in XYplorer? (@ Tools > Configuration > General > Refresh, Icons, History > Icons > (×) Show icon overlays)